luv: remove the default value of the $(PKG)_SOURCE variable
[buildroot-gz.git] / package / opus-tools / opus-tools.mk
blobde1b4399e3392d32b34c093f27a05b931ce0ab1f
1 ################################################################################
3 # opus-tools
5 ################################################################################
7 OPUS_TOOLS_VERSION = 0.1.9
8 OPUS_TOOLS_SITE = http://downloads.xiph.org/releases/opus
9 OPUS_TOOLS_LICENSE = BSD-2c
10 OPUS_TOOLS_LICENSE_FILES = COPYING
11 OPUS_TOOLS_CONF_OPTS = --disable-oggtest --disable-opustest
12 OPUS_TOOLS_DEPENDENCIES = opus libogg host-pkgconf
14 ifeq ($(BR2_PACKAGE_LIBPCAP),y)
15 OPUS_TOOLS_DEPENDENCIES += libpcap
16 endif
18 ifeq ($(BR2_X86_CPU_HAS_SSE),y)
19 OPUS_TOOLS_CONF_OPTS += --enable-sse
20 else
21 OPUS_TOOLS_CONF_OPTS += --disable-sse
22 endif
24 ifeq ($(BR2_PACKAGE_FLAC),y)
25 OPUS_TOOLS_DEPENDENCIES += flac
26 else
27 OPUS_TOOLS_CONF_OPTS += --without-flac
28 endif
30 $(eval $(autotools-package))