board/csky: fixup gdb instructions in readme.txt
[buildroot-gz.git] / package / strace / strace.mk
blob15a0fbf45144a4060a449fb23e2035de98fefe1e
1 ################################################################################
3 # strace
5 ################################################################################
7 STRACE_VERSION = 4.16
8 STRACE_SOURCE = strace-$(STRACE_VERSION).tar.xz
9 STRACE_SITE = http://downloads.sourceforge.net/project/strace/strace/$(STRACE_VERSION)
10 STRACE_LICENSE = BSD-3c
11 STRACE_LICENSE_FILES = COPYING
13 # strace bundle some kernel headers to build libmpers, this mixes userspace
14 # headers and kernel headers which break the build with musl.
15 # The stddef.h from gcc is used instead of the one from musl.
16 ifeq ($(BR2_TOOLCHAIN_USES_MUSL),y)
17 STRACE_CONF_OPTS += st_cv_m32_mpers=no \
18 st_cv_mx32_mpers=no
19 endif
21 define STRACE_REMOVE_STRACE_GRAPH
22 rm -f $(TARGET_DIR)/usr/bin/strace-graph
23 endef
25 STRACE_POST_INSTALL_TARGET_HOOKS += STRACE_REMOVE_STRACE_GRAPH
27 $(eval $(autotools-package))