board/csky: fixup gdb instructions in readme.txt
[buildroot-gz.git] / package / lirc-tools / lirc-tools.mk
blobbd0f96f337a9da98f2d85dff22f723a1d9a53615
1 ################################################################################
3 # lirc-tools
5 ################################################################################
7 LIRC_TOOLS_VERSION = 0.9.4b
8 LIRC_TOOLS_SOURCE = lirc-$(LIRC_TOOLS_VERSION).tar.bz2
9 LIRC_TOOLS_SITE = http://downloads.sourceforge.net/project/lirc/LIRC/$(LIRC_TOOLS_VERSION)
10 LIRC_TOOLS_LICENSE = GPLv2+
11 LIRC_TOOLS_LICENSE_FILES = COPYING
12 LIRC_TOOLS_DEPENDENCIES = host-libxslt host-pkgconf host-python3
13 LIRC_TOOLS_INSTALL_STAGING = YES
14 # 0002-configure-check-for-clock_gettime-in-librt.patch
15 LIRC_TOOLS_AUTORECONF = YES
17 LIRC_TOOLS_CONF_ENV = XSLTPROC=yes
18 LIRC_TOOLS_CONF_OPTS = --without-x
20 ifeq ($(BR2_PACKAGE_HAS_UDEV),y)
21 LIRC_TOOLS_DEPENDENCIES += udev
22 endif
24 ifeq ($(BR2_PACKAGE_ALSA_LIB),y)
25 LIRC_TOOLS_DEPENDENCIES += alsa-lib
26 endif
28 ifeq ($(BR2_PACKAGE_LIBUSB_COMPAT),y)
29 LIRC_TOOLS_DEPENDENCIES += libusb-compat
30 endif
32 ifeq ($(BR2_PACKAGE_PORTAUDIO),y)
33 LIRC_TOOLS_DEPENDENCIES += portaudio
34 endif
36 define LIRC_TOOLS_INSTALL_INIT_SYSV
37 $(INSTALL) -D -m 0755 package/lirc-tools/S25lircd \
38 $(TARGET_DIR)/etc/init.d/S25lircd
39 endef
41 $(eval $(autotools-package))