php-yaml: re add package, now compatible with PHP 7
[buildroot-gz.git] / package / php-yaml / php-yaml.mk
blob27118906d44a6b5599c591c4e2a7dd25e6dad405
1 ################################################################################
3 # php-yaml
5 ################################################################################
7 PHP_YAML_VERSION = 2.0.0RC7
8 PHP_YAML_SOURCE = yaml-$(PHP_YAML_VERSION).tgz
9 PHP_YAML_SITE = https://pecl.php.net/get
10 PHP_YAML_CONF_OPTS = --with-php-config=$(STAGING_DIR)/usr/bin/php-config \
11 --with-yaml=$(STAGING_DIR)/usr
12 # phpize does the autoconf magic
13 PHP_YAML_DEPENDENCIES = libyaml php host-autoconf
14 PHP_YAML_LICENSE = MIT
15 PHP_YAML_LICENSE_FILES = LICENSE
17 define PHP_YAML_PHPIZE
18 (cd $(@D); \
19 PHP_AUTOCONF=$(HOST_DIR)/usr/bin/autoconf \
20 PHP_AUTOHEADER=$(HOST_DIR)/usr/bin/autoheader \
21 $(STAGING_DIR)/usr/bin/phpize)
22 endef
24 PHP_YAML_PRE_CONFIGURE_HOOKS += PHP_YAML_PHPIZE
26 $(eval $(autotools-package))