configs/imx6qsabresd: Add ext4 rootfs option
[buildroot-gz.git] / package / beecrypt / beecrypt.mk
blobbd29b3b2c8f7161a1a15c9db6a03950eeb8d5db6
1 ################################################################################
3 # beecrypt
5 ################################################################################
7 BEECRYPT_VERSION = 4.2.1
8 BEECRYPT_SITE = http://downloads.sourceforge.net/project/beecrypt/beecrypt/$(BEECRYPT_VERSION)
9 BEECRYPT_AUTORECONF = YES
10 BEECRYPT_INSTALL_STAGING = YES
11 BEECRYPT_LICENSE = LGPLv2.1+
12 BEECRYPT_LICENSE_FILES = COPYING.LIB
14 BEECRYPT_CONF_OPTS = \
15 --disable-expert-mode \
16 --without-java \
17 --without-python \
18 --disable-openmp
20 # disable optimized m68k assembly as it doesn't compile for coldfire
21 ifeq ($(BR2_m68k_cf),y)
22 BEECRYPT_CONF_OPTS += --enable-debug
23 endif
25 # arm asm optimization doesn't work for thumb-only
26 ifeq ($(BR2_arm):$(BR2_ARM_CPU_HAS_ARM),y:)
27 BEECRYPT_CONF_OPTS += --enable-debug
28 endif
30 ifeq ($(BR2_PACKAGE_BEECRYPT_CPP),y)
31 BEECRYPT_DEPENDENCIES += icu
32 BEECRYPT_CONF_OPTS += --with-cplusplus
33 else
34 BEECRYPT_CONF_OPTS += --without-cplusplus
36 # automake/libtool uses the C++ compiler to link libbeecrypt because of
37 # (the optional) cppglue.cxx. Force it to use the C compiler instead.
38 define BEECRYPT_LINK_WITH_CC
39 $(SED) 's/--tag=CXX/--tag=CC/g' $(@D)/Makefile
40 endef
42 BEECRYPT_POST_CONFIGURE_HOOKS += BEECRYPT_LINK_WITH_CC
43 endif
45 $(eval $(autotools-package))