change package tarball compression to xz whenever possible
[buildroot-gz.git] / package / sg3_utils / sg3_utils.mk
blob8bb79b5744de4baba8ac32536d601e1284088cd3
1 ################################################################################
3 # sg3_utils
5 ################################################################################
7 SG3_UTILS_VERSION = 1.34
8 SG3_UTILS_SOURCE = sg3_utils-$(SG3_UTILS_VERSION).tar.xz
9 SG3_UTILS_SITE = http://sg.danny.cz/sg/p/
10 SG3_UTILS_LICENSE = BSD-3c
11 # utils progs are GPLv2+ licenced
12 ifeq ($(BR2_PACKAGE_SG3_UTILS_PROGS),y)
13 SG3_UTILS_LICENSE += GPLv2+
14 endif
15 SG3_UTILS_LICENSE_FILES = COPYING BSD_LICENSE
17 # install the libsgutils2 library
18 SG3_UTILS_INSTALL_STAGING = YES
20 ifeq ($(BR2_PACKAGE_SG3_UTILS_PROGS),)
21 define SG3_UTILS_REMOVE_PROGS
22 for prog in \
23 dd decode_sense emc_trespass format get_config \
24 get_lba_status ident inq logs luns map26 \
25 map sgm_dd modes opcodes sgp_dd persist prevent \
26 raw rbuf rdac read readcap read_block_limits \
27 read_buffer read_long reassign referrals \
28 requests reset rmsn rtpg safte sanitize \
29 sat_identify sat_phy_event sat_set_features scan \
30 senddiag ses start stpg sync test_rwbuf turs \
31 unmap verify vpd write_buffer write_long \
32 write_same wr_mode ; do \
33 $(RM) $(TARGET_DIR)/usr/bin/sg_$${prog} ; \
34 done
35 $(RM) $(TARGET_DIR)/usr/bin/sginfo
36 endef
38 SG3_UTILS_POST_INSTALL_TARGET_HOOKS += SG3_UTILS_REMOVE_PROGS
39 endif
41 $(eval $(autotools-package))