1 ################################################################################
5 ################################################################################
7 LIBSRTP_VERSION
= v1.5
.2
8 LIBSRTP_SITE
= $(call github
,cisco
,libsrtp
,$(LIBSRTP_VERSION
))
9 LIBSRTP_INSTALL_STAGING
= YES
10 LIBSRTP_LICENSE
= BSD-3c
11 LIBSRTP_LICENSE_FILES
= LICENSE
13 ifeq ($(BR2_STATIC_LIBS
),y
)
14 LIBSRTP_MAKE_OPTS
= libsrtp.a
15 else ifeq ($(BR2_SHARED_LIBS
),y
)
16 LIBSRTP_MAKE_OPTS
= shared_library
18 LIBSRTP_MAKE_OPTS
= libsrtp.a shared_library
21 # While libsrtp is not using pkg-config itself, it checks if
22 # pkg-config is available to determine whether it should install
23 # libsrtp.pc. Since installing it seems useful, let's depend on
24 # host-pkgconf to make sure pkg-config is installed.
25 LIBSRTP_DEPENDENCIES
= host-pkgconf
27 # openssl handling needs libdl support
28 ifeq ($(BR2_PACKAGE_OPENSSL
)x
$(BR2_STATIC_LIBS
),yx
)
29 LIBSRTP_DEPENDENCIES
+= openssl
30 LIBSRTP_CONF_OPTS
+= --enable-openssl
32 LIBSRTP_CONF_OPTS
+= --disable-openssl
35 $(eval
$(autotools-package
))