1 ################################################################################
5 ################################################################################
7 SNAPPY_VERSION
= 32d6d7d8a2ef328a2ee1dd40f072e21f4983ebda
8 SNAPPY_SITE
= $(call github
,google
,snappy
,$(SNAPPY_VERSION
))
9 SNAPPY_LICENSE
= BSD-3c
10 SNAPPY_LICENSE_FILES
= COPYING
12 SNAPPY_AUTORECONF
= YES
13 SNAPPY_DEPENDENCIES
= host-pkgconf
14 SNAPPY_INSTALL_STAGING
= YES
17 SNAPPY_CONF_OPTS
= --disable-gtest
19 # libsnappy links with libstdc++. Some libstdc++/arch variants use
20 # pthread symbols for internal locking if built with thead
21 # support. libstdc++ does not have a .pc file, and its .la file does
22 # not mention -pthread. So, static linkig to libstdc++ will fail if
23 # -pthread is not explicity linked to. Only do that for static builds.
24 ifeq ($(BR2_STATIC_LIBS
)$(BR2_TOOLCHAIN_HAS_THREADS
),yy
)
25 SNAPPY_CONF_OPTS
+= LIBS
=-pthread
28 $(eval
$(autotools-package
))