linux: bump default version to 4.10.5
[buildroot-gz.git] / package / snappy / snappy.mk
blobfcbcd1368f720ce4415b46de8b6776ab207d42b2
1 ################################################################################
3 # snappy
5 ################################################################################
7 SNAPPY_VERSION = 32d6d7d8a2ef328a2ee1dd40f072e21f4983ebda
8 SNAPPY_SITE = $(call github,google,snappy,$(SNAPPY_VERSION))
9 SNAPPY_LICENSE = BSD-3c
10 SNAPPY_LICENSE_FILES = COPYING
11 # from git
12 SNAPPY_AUTORECONF = YES
13 SNAPPY_DEPENDENCIES = host-pkgconf
14 SNAPPY_INSTALL_STAGING = YES
16 # Disable tests
17 SNAPPY_CONF_OPTS = --disable-gtest
19 # libsnappy links with libstdc++. Some libstdc++/arch variants use
20 # pthread symbols for internal locking if built with thead
21 # support. libstdc++ does not have a .pc file, and its .la file does
22 # not mention -pthread. So, static linkig to libstdc++ will fail if
23 # -pthread is not explicity linked to. Only do that for static builds.
24 ifeq ($(BR2_STATIC_LIBS)$(BR2_TOOLCHAIN_HAS_THREADS),yy)
25 SNAPPY_CONF_OPTS += LIBS=-pthread
26 endif
28 $(eval $(autotools-package))