linux: bump default version to 4.10.5
[buildroot-gz.git] / package / faifa / faifa.mk
bloba56a8c03325a595f944b99cd24a5301c41e9e68a
1 ################################################################################
3 # faifa
5 ################################################################################
7 FAIFA_VERSION = v0.1
8 FAIFA_SITE = $(call github,ffainelli,faifa,$(FAIFA_VERSION))
9 FAIFA_INSTALL_STAGING = YES
10 FAIFA_DEPENDENCIES = libpcap host-autoconf
11 FAIFA_LICENSE = BSD-3c
12 FAIFA_LICENSE_FILES = COPYING
14 FAIFA_MAKE_OPTS += GIT_REV=$(FAIFA_VERSION)
16 # This package uses autoconf, but not automake, so we need to call
17 # their special autogen.sh script, and have custom target and staging
18 # installation commands.
20 define FAIFA_RUN_AUTOGEN
21 cd $(@D) && PATH=$(BR_PATH) ./autogen.sh
22 endef
23 FAIFA_PRE_CONFIGURE_HOOKS += FAIFA_RUN_AUTOGEN
25 define FAIFA_INSTALL_TARGET_CMDS
26 $(TARGET_CONFIGURE_OPTS) $(MAKE) -C $(@D) \
27 PREFIX=/usr \
28 STRIP=/bin/true \
29 DESTDIR=$(TARGET_DIR) \
30 install
31 endef
33 define FAIFA_INSTALL_STAGING_CMDS
34 $(TARGET_CONFIGURE_OPTS) $(MAKE) -C $(@D) \
35 PREFIX=/usr \
36 STRIP=/bin/true \
37 DESTDIR=$(STAGING_DIR) \
38 install
39 endef
41 $(eval $(autotools-package))