lua-bit32: new package
[buildroot-gz.git] / package / czmq / czmq.mk
blob8c4de7186bf45f316e9a9ef1be7bb8f9cb56e4e0
1 ################################################################################
3 # czmq
5 ################################################################################
7 CZMQ_VERSION = 5205ec201e97c3a652c17eb86b18b70350b54512
8 CZMQ_SITE = $(call github,zeromq,czmq,$(CZMQ_VERSION))
10 # Autoreconf required as we use the git tree
11 CZMQ_AUTORECONF = YES
12 CZMQ_INSTALL_STAGING = YES
13 CZMQ_DEPENDENCIES = zeromq host-pkgconf
14 CZMQ_LICENSE = MPLv2.0
15 CZMQ_LICENSE_FILES = LICENSE
17 # asciidoc is a python script that imports unicodedata, which is not in
18 # host-python, so disable asciidoc entirely.
19 CZMQ_CONF_ENV = ac_cv_prog_czmq_have_asciidoc=no
21 define CZMQ_CREATE_CONFIG_DIR
22 mkdir -p $(@D)/config
23 endef
25 CZMQ_POST_PATCH_HOOKS += CZMQ_CREATE_CONFIG_DIR
27 $(eval $(autotools-package))