package/bullet: bump to version 2.85.1
[buildroot-gz.git] / package / opkg / opkg.mk
blobbf19a60fbf92efcec431e3c665cd6e6cd6d3f5a9
1 ################################################################################
3 # opkg
5 ################################################################################
7 OPKG_VERSION = v0.3.1
8 OPKG_SITE = http://git.yoctoproject.org/git/opkg
9 OPKG_SITE_METHOD = git
10 # Uses PKG_CHECK_MODULES() in configure.ac
11 OPKG_DEPENDENCIES = host-pkgconf libarchive
12 OPKG_LICENSE = GPLv2+
13 OPKG_LICENSE_FILES = COPYING
14 OPKG_INSTALL_STAGING = YES
15 OPKG_CONF_OPTS = --disable-curl
16 OPKG_AUTORECONF = YES
18 # Ensure directory for lockfile exists
19 define OPKG_CREATE_LOCKDIR
20 mkdir -p $(TARGET_DIR)/usr/lib/opkg
21 endef
23 ifeq ($(BR2_PACKAGE_OPKG_GPG_SIGN),y)
24 OPKG_CONF_OPTS += --enable-gpg
25 OPKG_CONF_ENV += \
26 ac_cv_path_GPGME_CONFIG=$(STAGING_DIR)/usr/bin/gpgme-config \
27 ac_cv_path_GPGERR_CONFIG=$(STAGING_DIR)/usr/bin/gpg-error-config
28 OPKG_DEPENDENCIES += libgpgme libgpg-error
29 else
30 OPKG_CONF_OPTS += --disable-gpg
31 endif
33 OPKG_POST_INSTALL_TARGET_HOOKS += OPKG_CREATE_LOCKDIR
35 $(eval $(autotools-package))