1 ################################################################################
5 ################################################################################
7 LIBSSH2_VERSION
= 1.5.0
8 LIBSSH2_SITE
= http
://www.libssh2.org
/download
10 LIBSSH2_LICENSE_FILES
= COPYING
11 LIBSSH2_INSTALL_STAGING
= YES
12 LIBSSH2_CONF_OPTS
= --disable-examples-build
14 # libssh2 must use either libgcrypt or OpenSSL
15 # Only select openssl if libgcrypt is not selected
16 ifeq ($(BR2_PACKAGE_LIBGCRYPT
),y
)
17 LIBSSH2_DEPENDENCIES
+= libgcrypt
18 LIBSSH2_CONF_OPTS
+= --with-libgcrypt \
19 --with-libgcrypt-prefix
=$(STAGING_DIR
)/usr \
21 # configure.ac forgets to link to dependent libraries of gcrypt breaking static
23 LIBSSH2_CONF_ENV
+= LIBS
="$(shell $(STAGING_DIR)/usr/bin/libgcrypt-config --libs)"
25 LIBSSH2_DEPENDENCIES
+= openssl
26 LIBSSH2_CONF_OPTS
+= --with-openssl \
27 --with-libssl-prefix
=$(STAGING_DIR
)/usr \
31 # Add zlib support if enabled
32 ifeq ($(BR2_PACKAGE_ZLIB
),y
)
33 LIBSSH2_DEPENDENCIES
+= zlib
34 LIBSSH2_CONF_OPTS
+= --with-libz \
35 --with-libz-prefix
=$(STAGING_DIR
)/usr
37 LIBSSH2_CONF_OPTS
+= --without-libz
40 $(eval
$(autotools-package
))