net-misc/mbpoll: make pkgcheck happy
[booboo.git] / dev-embedded / libmpsse / libmpsse-9999.ebuild
blob7ead2284f6ae05a695781fb0d8fde8abb74f3360
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=8
6 inherit autotools
8 DESCRIPTION="Open source library for SPI/I2C control via FTDI chips"
9 HOMEPAGE="https://github.com/l29ah/libmpsse"
11 if [[ ${PV} == *9999* ]]; then
12 inherit git-r3
13 EGIT_REPO_URI="https://github.com/l29ah/libmpsse"
14 else
15 SRC_URI="https://github.com/l29ah/libmpsse/archive/v${PV}.tar.gz -> ${P}.tar.gz"
16 KEYWORDS="~x86 ~amd64"
19 LICENSE="BSD-2"
20 SLOT="0"
21 IUSE="doc examples"
23 RDEPEND="dev-embedded/libftdi:0"
24 DEPEND="dev-lang/swig
25 ${RDEPEND}"
27 S="${WORKDIR}/$P/src"
29 src_prepare() {
30 default
32 eautoreconf
35 src_configure() {
36 econf --disable-python
39 src_install() {
40 emake DESTDIR="${D}" install
41 dodoc ../README.md
42 dodoc ../docs/README*
43 if use doc ; then
44 dodoc ../docs/AN_135_MPSSE_Basics.pdf
46 if use examples ; then
47 insinto /usr/share/${PN}/
48 doins -r examples