2 # -*- mode: makefile; coding: utf-8 -*-
4 #DEB_MAKE_CHECK_TARGET = test_bitcoin
6 # $(if $(filter nocheck,$(DEB_BUILD_OPTIONS)),,src/test_bitcoin)
9 dh
--with bash-completion
$@
11 override_dh_auto_clean
:
12 if
[ -f Makefile
]; then
$(MAKE
) distclean; fi
13 rm -rf Makefile.in aclocal.m4 configure src
/Makefile.in src
/bitcoin-config.h.in src
/build-aux src
/qt
/Makefile.in src
/qt
/test/Makefile.in src
/test/Makefile.in
15 QT
=$(shell dpkg-vendor
--derives-from Ubuntu
&& echo qt4 || echo qt5
)
17 # Yea, autogen should be run on the source archive, but I like doing git archive
18 override_dh_auto_configure
:
20 .
/configure
--with-gui
=$(QT
)
22 override_dh_auto_test
: