Better NAT support
[bcusdk.git] / bcusdk.spec
blobec967be072a9bc35532293bfd162c8c922c3c18a
1 Name: bcusdk
2 Version: 0.0.4
3 Release: 1
4 Summary: BCU SDK
6 Group: Development/Tools
7 License: GPL
8 URL: http://www.auto.tuwien.ac.at/~mkoegler/index.php/bcusdk
9 Source0: bcusdk_%{version}.tar.gz
10 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
12 BuildRequires: libxml2-devel, gcc-c++, make, flex, bison, libpthsem-devel, m68hc05-gcc, gcc-java, indent
13 %if 0%{?suse_version} > 910
14 BuildRequires: fastjar
15 %endif
16 Requires: eibd-server, eibd-clients, eibd-client-sources, libeibclient-devel, bcusdk-build
18 %description
19 A SDK to develop application for EIB BCU 1 and 2.
21 %package -n eibd-server
22 Summary: eibd server
23 Group: Development/Tools
25 %description -n eibd-server
26 eibd is a daemon, which supports connection to an EIB bus over various
27 access devices and provide its services over TCP/IP or Unix domain sockets.
28 Note: Some backends may crash Linux 2.6 kernels before 2.6.11.
30 %package -n eibd-clients
31 Summary: eibd clients
32 Group: Development/Tools
34 %description -n eibd-clients
35 provides simple example programs to perform some management task on a EIB system.
37 %package -n libeibclient0
38 Summary: eibd client library
39 Group: Development/Tools
41 %description -n libeibclient0
42 provides a simple client library written in C to access the EIB bus over eibd.
44 %package -n libeibclient-devel
45 Summary: eibd client library
46 Requires: libeibclient0
47 Group: Development/Tools
49 %description -n libeibclient-devel
50 provides a simple client library written in C to access the EIB bus over eibd.
52 %package -n eibd-client-sources
53 Summary: sources of the eibd client programs
54 Group: Development/Tools
56 %description -n eibd-client-sources
57 provides the source of the eibd client programs as examples how to use
58 the eibd client library.
60 %package -n bcusdk-build
61 Requires: m68hc05-gcc, libxslt
62 Summary: BCU SDK image building programs
63 Group: Development/Tools
65 %description -n bcusdk-build
66 contains all files and programs to build BCU images
68 # no debug package + strip
69 %define __spec_install_post %{nil}
70 %define debug_package %{nil}
73 %prep
74 %setup -q -n bcusdk-%{version}
77 %build
78 %configure --enable-ft12 --enable-pei16 --enable-tpuart --enable-pei16s --enable-tpuarts \
79 --enable-eibnetip --enable-eibnetipserver --enable-eibnetiptunnel --enable-usb --enable-groupcache --enable-java
80 make %{?_smp_mflags}
83 %install
84 rm -rf $RPM_BUILD_ROOT
85 make install DESTDIR=$RPM_BUILD_ROOT
88 %clean
89 rm -rf $RPM_BUILD_ROOT
91 %post -n libeibclient0 -p /sbin/ldconfig
93 %postun -n libeibclient0 -p /sbin/ldconfig
95 %files
96 %defattr(-,root,root,-)
97 %doc README
99 %files -n bcusdk-build
100 %defattr(-,root,root,-)
101 /usr/share/bcusdk/include
102 /usr/share/bcusdk/ldscripts
103 /usr/share/bcusdk/xml
104 %{_libdir}/bcusdk/lib
105 /usr/bin/build.ai
106 /usr/bin/build.img
107 /usr/bin/build.dev
108 /usr/bin/bcugen1
109 /usr/bin/bcugen2
110 /usr/bin/bcugen3
111 /usr/bin/embedprogid
112 /usr/bin/extractprogid
113 /usr/bin/gencitemplate
114 /usr/bin/viewimage
115 /usr/bin/loadimage
116 /usr/bin/imageedit
117 /usr/share/bcusdk/examples/*.xml
119 %files -n eibd-server
120 %defattr(-,root,root,-)
121 /usr/bin/eibd
122 /usr/bin/bcuaddrtab
123 /usr/bin/bcuread
124 /usr/bin/eibnetdescribe
125 /usr/bin/eibnetsearch
126 /usr/bin/findknxusb
128 %files -n eibd-clients
129 %defattr(-,root,root,-)
130 /usr/bin/busmonitor1
131 /usr/bin/busmonitor2
132 /usr/bin/vbusmonitor1
133 /usr/bin/vbusmonitor1poll
134 /usr/bin/vbusmonitor2
135 /usr/bin/groupread
136 /usr/bin/groupswrite
137 /usr/bin/groupwrite
138 /usr/bin/groupsresponse
139 /usr/bin/groupresponse
140 /usr/bin/grouplisten
141 /usr/bin/madcread
142 /usr/bin/maskver
143 /usr/bin/mmaskver
144 /usr/bin/mread
145 /usr/bin/mwrite
146 /usr/bin/mprogmodeon
147 /usr/bin/mprogmodeoff
148 /usr/bin/mprogmodestatus
149 /usr/bin/mprogmodetoggle
150 /usr/bin/progmodeon
151 /usr/bin/progmodeoff
152 /usr/bin/progmodestatus
153 /usr/bin/progmodetoggle
154 /usr/bin/mpropdesc
155 /usr/bin/mpropread
156 /usr/bin/mpropwrite
157 /usr/bin/mpropscan
158 /usr/bin/mpropscanpoll
159 /usr/bin/readindividual
160 /usr/bin/writeaddress
161 /usr/bin/mpeitype
162 /usr/bin/msetkey
163 /usr/bin/groupsocketlisten
164 /usr/bin/groupsocketread
165 /usr/bin/groupsocketwrite
166 /usr/bin/groupsocketswrite
167 /usr/bin/groupreadresponse
168 /usr/bin/groupcacheenable
169 /usr/bin/groupcachedisable
170 /usr/bin/groupcacheclear
171 /usr/bin/groupcacheremove
172 /usr/bin/groupcachereadsync
173 /usr/bin/groupcacheread
174 /usr/bin/groupcachelastupdates
175 /usr/bin/mrestart
176 /usr/bin/mwriteplain
177 /usr/bin/knxtool
178 /usr/bin/xpropread
179 /usr/bin/xpropwrite
181 %files -n libeibclient0
182 %defattr(-,root,root,-)
183 %{_libdir}/libeibclient.so.*
185 %files -n libeibclient-devel
186 %defattr(-,root,root,-)
187 /usr/include/*
188 %{_libdir}/libeibclient.la
189 %{_libdir}/libeibclient.a
190 %{_libdir}/libeibclient.so
191 /usr/share/bcusdk/eibclient.php
192 /usr/share/bcusdk/EIBConnection.cs
193 /usr/share/bcusdk/EIBConnection.pm
194 /usr/share/bcusdk/EIBConnection.py
195 /usr/share/bcusdk/EIBD.pas
196 /usr/share/java/eibclient.jar
198 %files -n eibd-client-sources
199 %defattr(-,root,root,-)
200 /usr/share/bcusdk/examples/*.c
201 /usr/share/bcusdk/examples/*.h
204 %changelog
205 * Sat Jul 30 2005 Martin Koegler <mkoegler@auto.tuwien.ac.at> - 0:0.0.0-3
206 - first version