Finally added basic title support, cleaned up more code
[baulk.git] / pkg / PKGBUILD
blob78b1d762d4ee318449dc69513e628a2cc02149af
1 #| Local Source PKGBUILD
2 pkgname=baulk
3 pkgver=0.1
4 pkgrel=1
5 pkgdesc="Baulk is a cross-platform native application tiling management tool written in Qt4. An emphasis is made on making all major components a separate dynamic library, for modularity."
6 arch=('i686' 'x86_64')
7 url="http://baulk.sf.net"
8 license=('GPL')
9 depends=('qt')
10 makedepends=('cmake>=2.6.0' 'pkgconfig' 'doxygen' 'graphviz')
11 provides=('baulk')
12 conflicts=('baulk')
13 source=()
14 md5sums=()
16 build() {
17         cmake -DCMAKE_INSTALL_PREFIX=/usr -DBuildBaulk=true .. || return 1
18         make clean || return 1
19         make -j10 || return 1
20         make DESTDIR=$pkgdir install || return 1