Updating templates to new comment stylings
[baulk.git] / pkg / PKGBUILD-git
blob7dfd9a82b8e1fd3a55c801190825875be365cb82
1 pkgname=baulk
2 pkgver=20081106
3 pkgrel=1
4 pkgdesc="Baulk is a cross-platform native application tiling management tool written in Qt4. An emphasis is made on making all major components a separate dynamic library, for modularity."
5 arch=('i686' 'x86_64')
6 url="http://baulk.sf.net"
7 license=('GPL')
8 depends=('qt')
9 makedepends=('git' 'cmake>=2.6.0' 'pkgconfig' 'cvs' 'doxygen' 'graphviz')
10 provides=('baulk')
11 conflicts=('baulk')
12 source=()
13 md5sums=()
15 _gitroot="git://gitorious.org/baulk/mainline.git"
16 _gitname="baulk"
18 build() {
19         cd $srcdir
21         msg "Perusing git handles..."
22         if [[ -d $_gitname ]]; then
23                 ( cd $_gitname && git pull origin )
24         else
25                 git clone $_gitroot $_gitname
26         fi
28         msg "Git tea is ready, or it spilt all over you."
29         msg "Building..."
31         rm -rf $_gitname-build
32         cp -r $_gitname $_gitname-build
33         cd $_gitname-build
35         cmake -DCMAKE_INSTALL_PREFIX=/usr -DBuildBaulk=true || return 1
36         make || return 1
37         make DESTDIR=$pkgdir install || return 1