Updated command line options
[baulk.git] / pkg / debian / rules
blobfc6096c6e5de3e18f71b3622040417be2b230c03
1 #!/usr/bin/make -f
2 #| This file was originally written by Joey Hess and Craig Small.
4 #| Uncomment this to turn on verbose mode.
5 #export DH_VERBOSE=1
7 CFLAGS = -Wall -g
9 ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
10 CFLAGS += -O0
11 else
12 CFLAGS += -O2
13 endif
16 configure: configure-stamp
17 configure-stamp:
18 dh_testdir
19 cmake -DCMAKE_INSTALL_PREFIX=/usr $(CURDIR)
20 touch configure-stamp
23 build: build-stamp
24 build-stamp: configure-stamp
25 dh_testdir
27 $(MAKE) -j10
29 touch $@
32 clean:
33 dh_testdir
34 dh_testroot
35 rm -f build-stamp configure-stamp
37 -$(MAKE) clean
39 dh_clean
42 install: build
43 dh_testdir
44 dh_testroot
45 dh_clean -k
46 dh_installdirs
48 $(MAKE) DESTDIR=$(CURDIR)/debian/tmp install
51 #| Build architecture-independent files here.
52 binary-indep: build install
55 #| Build architecture-dependent files here.
56 binary-arch: build install
57 dh_testdir
58 dh_testroot
59 dh_installchangelogs
60 dh_installdocs
61 dh_installexamples
62 dh_install --sourcedir=debian/tmp
63 dh_installman
64 dh_link
65 dh_strip
66 dh_compress
67 dh_fixperms
68 dh_makeshlibs
69 dh_installdeb
70 dh_shlibdeps
71 dh_gencontrol
72 dh_md5sums
73 dh_builddeb
76 binary: binary-indep binary-arch
77 .PHONY: build clean binary-indep binary-arch binary install configure