2 # Based on the multi2 sample debian/rules file:
4 # Sample debian/rules that uses debhelper.
5 # This file is public domain software, originally written by Joey Hess.
8 include /usr
/share
/cdbs
/1/rules
/debhelper.mk
9 include /usr
/share
/cdbs
/1/class
/autotools.mk
10 #include /usr/share/cdbs/1/rules/simple-patchsys.mk
15 # in which directory to build
18 # in which directory to install the sofware
19 DEB_DESTDIR
= $(CURDIR
)/debian
/tmp
21 #CDBS automatically handles common flags to pass to the configure script,
22 #but it is possible to give some extra parameters :
23 DEB_CONFIGURE_EXTRA_FLAGS
:= --enable-boost
--enable-nls
--with-zlib
--enable-gui
--enable-desktop
$(BARRY_CONFIGURE_OPTS
) --with-libusb
--enable-rpathhack
--with-evolution
24 COMMON_CONFIGURE_FLAGS
:= --prefix=/usr
25 DEB_INSTALL_DOCS_ALL
=
28 ifeq ($(DEB_HOST_ARCH_OS
), linux
)
29 # Install udev rules for the barry-util package
30 install -d
$(CURDIR
)/debian
/barry-util
/lib
/udev
/rules.d
32 $(DEB_SRCDIR
)/udev
/10-blackberry.rules \
33 $(DEB_SRCDIR
)/udev
/99-blackberry-perms.rules \
34 $(CURDIR
)/debian
/barry-util
/lib
/udev
/rules.d
36 # Install modprobe blacklist file for bcharge, into barry-util package
37 install -d
$(CURDIR
)/debian
/barry-util
/etc
/modprobe.d
38 install -m
0644 $(DEB_SRCDIR
)/modprobe
/blacklist-berry_charge.conf
$(CURDIR
)/debian
/barry-util
/etc
/modprobe.d
/blacklist-berry_charge.conf
39 # Install default ppp options and chat scripts
40 install -d
$(CURDIR
)/debian
/barry-util
/etc
/ppp
/peers
42 $(DEB_SRCDIR
)/ppp
/barry-rogers \
43 $(DEB_SRCDIR
)/ppp
/barry-minimal \
44 $(DEB_SRCDIR
)/ppp
/barry-verizon \
45 $(DEB_SRCDIR
)/ppp
/barry-sprint \
46 $(DEB_SRCDIR
)/ppp
/barry-telus \
47 $(DEB_SRCDIR
)/ppp
/barry-o2ireland \
48 $(DEB_SRCDIR
)/ppp
/barry-tmobileus \
49 $(DEB_SRCDIR
)/ppp
/barry-att_cingular \
50 $(DEB_SRCDIR
)/ppp
/barry-chinamobile \
51 $(DEB_SRCDIR
)/ppp
/barry-kpn \
52 $(DEB_SRCDIR
)/ppp
/barry-orange-spain \
53 $(DEB_SRCDIR
)/ppp
/barry-orangeuk \
54 $(DEB_SRCDIR
)/ppp
/barry-mts \
55 $(DEB_SRCDIR
)/ppp
/barry-optus-au \
56 $(DEB_SRCDIR
)/ppp
/barry-vodafone-au \
57 $(CURDIR
)/debian
/barry-util
/etc
/ppp
/peers
58 install -d
$(CURDIR
)/debian
/barry-util
/etc
/chatscripts
60 $(DEB_SRCDIR
)/ppp
/barry-rogers.chat \
61 $(DEB_SRCDIR
)/ppp
/barry-minimal.chat \
62 $(DEB_SRCDIR
)/ppp
/barry-verizon.chat \
63 $(DEB_SRCDIR
)/ppp
/barry-sprint.chat \
64 $(DEB_SRCDIR
)/ppp
/barry-telus.chat \
65 $(DEB_SRCDIR
)/ppp
/barry-o2ireland.chat \
66 $(DEB_SRCDIR
)/ppp
/barry-tmobileus.chat \
67 $(DEB_SRCDIR
)/ppp
/barry-att_cingular.chat \
68 $(DEB_SRCDIR
)/ppp
/barry-chinamobile.chat \
69 $(DEB_SRCDIR
)/ppp
/barry-kpn.chat \
70 $(DEB_SRCDIR
)/ppp
/barry-orange-spain.chat \
71 $(DEB_SRCDIR
)/ppp
/barry-orangeuk.chat \
72 $(DEB_SRCDIR
)/ppp
/barry-mts.chat \
73 $(DEB_SRCDIR
)/ppp
/barry-optus-au.chat \
74 $(DEB_SRCDIR
)/ppp
/barry-vodafone-au.chat \
75 $(CURDIR
)/debian
/barry-util
/etc
/chatscripts
76 # Install hal fdi configs
77 install -d
$(CURDIR
)/debian
/barry-util
/usr
/share
/hal
/fdi
/information
/10freedesktop
78 install -d
$(CURDIR
)/debian
/barry-util
/usr
/share
/hal
/fdi
/policy
/10osvendor
79 install -m
0644 $(DEB_SRCDIR
)/hal
/fdi
/information
/10freedesktop
/10-blackberry.fdi
$(CURDIR
)/debian
/barry-util
/usr
/share
/hal
/fdi
/information
/10freedesktop
80 install -m
0644 $(DEB_SRCDIR
)/hal
/fdi
/policy
/10osvendor
/19-blackberry-acl.fdi
$(CURDIR
)/debian
/barry-util
/usr
/share
/hal
/fdi
/policy
/10osvendor
81 # Install hal support script
82 install -d
$(CURDIR
)/debian
/barry-util
/usr
/bin
83 install -m
0755 $(DEB_SRCDIR
)/hal
/hal-blackberry
$(CURDIR
)/debian
/barry-util
/usr
/bin
84 # Install bash and zsh completion scripts
85 install -d
$(CURDIR
)/debian
/barry-util
/etc
/bash_completion.d
87 $(DEB_SRCDIR
)/bash
/bjavaloader \
88 $(DEB_SRCDIR
)/bash
/btool \
89 $(CURDIR
)/debian
/barry-util
/etc
/bash_completion.d
90 # Install examples/ into libbarry-dev
91 install -d
$(CURDIR
)/debian
/libbarry-dev
/usr
/share
/doc
/libbarry-dev
/examples
92 install -m
0644 $(DEB_SRCDIR
)/examples
/*.
cc \
93 $(CURDIR
)/debian
/libbarry-dev
/usr
/share
/doc
/libbarry-dev
/examples
95 install/barrybackup-gui
::
97 install -d
$(CURDIR
)/debian
/barrybackup-gui
/usr
/share
/pixmaps
98 install -m
0644 $(DEB_SRCDIR
)/logo
/barry_logo_debian_menu_icon.xpm
$(CURDIR
)/debian
/barrybackup-gui
/usr
/share
/pixmaps
/barry_backup_menu_icon.xpm
99 # Install Gnome .desktop file
100 install -d
$(CURDIR
)/debian
/barrybackup-gui
/usr
/share
/applications
101 install -m
0644 $(DEB_SRCDIR
)/menu
/barrybackup.desktop
$(CURDIR
)/debian
/barrybackup-gui
/usr
/share
/applications
103 install/barrydesktop
::
105 install -d
$(CURDIR
)/debian
/barrydesktop
/usr
/share
/pixmaps
106 install -m
0644 $(DEB_SRCDIR
)/logo
/barry_logo_debian_menu_icon.xpm
$(CURDIR
)/debian
/barrydesktop
/usr
/share
/pixmaps
/barry_desktop_menu_icon.xpm
107 # Install Gnome .desktop file
108 install -d
$(CURDIR
)/debian
/barrydesktop
/usr
/share
/applications
109 install -m
0644 $(DEB_SRCDIR
)/menu
/barrydesktop.desktop
$(CURDIR
)/debian
/barrydesktop
/usr
/share
/applications
112 @
rm -f
$(CURDIR
)/deb_srcdir
113 @ln
-s
$(DEB_SRCDIR
) $(CURDIR
)/deb_srcdir
114 @
test -x
$(DEB_SRCDIR
)/configure
&& echo
"allready autoreconf" ||
(cd
$(DEB_SRCDIR
) && autoreconf
-i
)
117 # DEB_SRCDIR can be relative, so change into directory to use pwd.
119 # Note: that the compiler flags below depend on opensync-plugin's
120 # debian/rules having a DESTDIR target of opensync-plugin/debian/tmp
121 (cd
$(DEB_SRCDIR
) && \
122 export TREE_BUILD_CXXFLAGS
="-I`pwd`/opensync-plugin/debian/tmp/usr/include/barry18" && \
123 export TREE_BUILD_LDFLAGS
="-L`pwd`/opensync-plugin/debian/tmp/usr/lib" && \
124 export PKG_CONFIG_PATH
="`pwd`:$(PKG_CONFIG_PATH)" && \
125 export LD_LIBRARY_PATH
="`pwd`/opensync-plugin/debian/tmp/usr/lib:$(LD_LIBRARY_PATH)" && \
126 cd opensync-plugin
&& \
127 debian
/rules TREE_BUILD_DIR
="`pwd`/.." binary
)
130 (cd
$(DEB_SRCDIR
)/opensync-plugin
&& debian
/rules
clean)
133 # DEB_SRCDIR can be relative, so change into directory to use pwd.
135 # Note: that the compiler flags below depend on opensync-plugin-0.4x's
136 # debian/rules having a DESTDIR target of opensync-plugin-0.4x/debian/tmp
137 (cd
$(DEB_SRCDIR
) && \
138 export TREE_BUILD_CXXFLAGS
="-I`pwd`/opensync-plugin-0.4x/debian/tmp/usr/include/barry18" && \
139 export TREE_BUILD_LDFLAGS
="-L`pwd`/opensync-plugin-0.4x/debian/tmp/usr/lib" && \
140 export PKG_CONFIG_PATH
="`pwd`:$(PKG_CONFIG_PATH)" && \
141 export LD_LIBRARY_PATH
="`pwd`/opensync-plugin-0.4x/debian/tmp/usr/lib:$(LD_LIBRARY_PATH)" && \
142 cd opensync-plugin-0.4x
&& \
143 debian
/rules TREE_BUILD_DIR
="`pwd`/.." binary
)
146 (cd
$(DEB_SRCDIR
)/opensync-plugin-0.4x
&& debian
/rules
clean)
149 -@
rm -f
$(CURDIR
)/deb_srcdir