2 # Ideally, the evolution source path autodetection routines would
3 # load libebook and libecal dynamically, so that dependencies would
4 # not force the inclusion of evolution-data-server and friends.
6 # But there are two problems with that, which need to be
9 # - the glib major version numbers, according to the .so
10 # files, are not consistent between distros
11 # - when used dynamically, in a program that is not otherwise
12 # linked to glib, it can segfault... and it seems to get
13 # funky somewhere inside glib itself... so I'm guessing that
14 # the library is not being initialized properly :-(
16 # All this means that general compilations of barrydesktop will
17 # need evolution-data-server and friends linked in. It is possible
18 # to compile without by supplying --without-evolution on the configure
19 # command line, but then you risk getting a weak auto-detection
20 # of data sources in newer versions of evolution. If your data
21 # sources are located in paths like this:
23 # file:///home/cdfrey/.evolution/addressbook/local/system
25 # then it is safe to disable evolution for the barrydesktop compile.
27 # Otherwise, if your version of evolution is new, and uses funkier names,
28 # or uses local:system, or puts its files under ~/.config, then
29 # build --with-evolution and link against it.
34 Maintainer: Chris Frey <cdfrey@foursquare.net>
35 Build-Depends: debhelper (>= 7.0.0), g++ (>= 4.1), cdbs, autoconf, automake, libtool, pkg-config, libusb-dev, libboost-serialization-dev, libxml++2.6-dev, libfuse-dev (>= 2.5), zlib1g-dev, libtar-dev, libglib2.0-dev, libgtkmm-2.4-dev, libglademm-2.4-dev, gettext (<< 0.18) | autopoint, libgcal-dev, wx-common, libwxgtk2.8-dev, evolution-data-server-dev, libebook1.2-dev, libedata-book1.2-dev, libedata-cal1.2-dev, libedataserver1.2-dev
36 Standards-Version: 3.9.1
37 Homepage: http://netdirect.ca/barry
42 Depends: ${shlibs:Depends}
43 Description: Library for using the BlackBerry handheld on Linux
44 Barry is a GPL C++ library for interfacing with the RIM BlackBerry Handheld.
46 This package contains shared libraries.
48 Package: libbarry18-dbg
52 Depends: libbarry18 (= ${binary:Version})
53 Description: Library for using the BlackBerry handheld and debugging symbols
54 Barry is a GPL C++ library for interfacing with the RIM BlackBerry Handheld.
56 This package contains the debug version of the shared library.
61 Depends: libbarry18 (= ${binary:Version})
62 Description: Development files for libbarry
63 Barry is a GPL C++ library for interfacing with the RIM BlackBerry Handheld.
65 This package contains the header files required for building applications
71 Depends: libbarry18, udev (>= 0.056) [linux-any], python, ${shlibs:Depends}
73 Description: Command line utilities for working with the RIM BlackBerry Handheld
74 Barry is a GPL C++ library for interfacing with the RIM BlackBerry Handheld.
76 This package contains command line utilities, such as bcharge, btool,
79 Package: barry-util-dbg
83 Depends: barry-util (= ${binary:Version})
84 Description: Command line BlackBerry utilities and debugging symbols
85 Barry is a GPL C++ library for interfacing with the RIM BlackBerry Handheld.
87 This package contains the debug versions of the command line utilities.
89 Package: barrybackup-gui
92 Depends: libbarry18, ${shlibs:Depends}
93 Description: GTK+ GUI for backing up the RIM BlackBerry Handheld
94 Barry is a GPL C++ library for interfacing with the RIM BlackBerry Handheld.
96 This package contains a GUI application for making backups and restores.
98 Package: barrybackup-gui-dbg
102 Depends: barrybackup-gui (= ${binary:Version})
103 Description: GTK+ GUI for backing up BlackBerry and debugging symbols
104 Barry is a GPL C++ library for interfacing with the RIM BlackBerry Handheld.
106 This package contains the debug version of the backup GUI.
108 Package: barrydesktop
111 Depends: libbarry18, ${shlibs:Depends}
112 Description: Desktop Panel GUI for the RIM BlackBerry Handheld
113 Barry is a GPL C++ library for interfacing with the RIM BlackBerry Handheld.
115 This package contains a GUI management application for backups, syncing, etc.
117 Package: barrydesktop-dbg
121 Depends: barrydesktop (= ${binary:Version})
122 Description: Desktop Panel GUI for the RIM BlackBerry Handheld
123 Barry is a GPL C++ library for interfacing with the RIM BlackBerry Handheld.
125 This package contains the debug files for the Barry desktop.
129 #Description: Documentation for barry
130 # Barry is a GPL C++ library for interfacing with the RIM BlackBerry Handheld.
131 # It comes with a command line tool for exploring the device and for making quick
132 # backups. The goal of this project is to create a fully functional syncing
133 # mechanism on Linux.