Minor doc tweaks
[barry/progweb.git] / rpm / barry.spec
blobc2fe64d9d5e35ec6d8412ca470720b136908f8bf
1 %dump
3 # enable GUI using: --with gui
4 %define with_gui 0%{?_with_gui:1}
6 # enable opensync 0.2x using: --with opensync
7 %define with_opensync 0%{?_with_opensync:1}
9 # enable opensync 0.4x using: --with opensync4x
10 %define with_opensync4x 0%{?_with_opensync4x:1}
12 # enable desktop using: --with desktop
13 %define with_desktop 0%{?_with_desktop:1}
15 # slight change in udev, fedora 12 and later
16 %if 0%{?fc12} || 0%{?fc13} || 0%{?fc14} || 0%{?fc15}
17 %define use_69_rules 1
18 %else
19 %define use_69_rules 0
20 %endif
23 Summary: BlackBerry(tm) Desktop for Linux
24 Name: barry
25 Version: 0.18.0
26 Release: 0
27 Group: Applications/Productivity
28 License: GPLv2+
29 Source: %{name}-%{version}.tar.bz2
30 URL: http://www.netdirect.ca/software/packages/barry
31 Vendor: Net Direct Inc.
32 BuildRoot: %{_tmppath}/%{name}-%{release}-%{version}-root
34 BuildRequires: libusb-devel, gcc-c++, pkgconfig, boost-devel, fuse-devel, zlib-devel
36 %if %{with_gui}
37 BuildRequires: desktop-file-utils
38 %endif
40 # desktop tree
41 %if %{with_desktop}
42 BuildRequires: wxGTK-devel
43 %endif
45 %define barryroot %{_builddir}/%{name}-%{version}
47 %description
48 Barry is a desktop toolset for managing your BlackBerry(tm) device. (BlackBerry
49 is a registered trademark of Research in Motion Limited.)
52 %package -n libbarry0
53 Summary: BlackBerry(tm) Desktop for Linux - libbarry libraries
54 Group: Development/Libraries
55 Requires: libusb boost
57 %description -n libbarry0
58 Barry is a desktop toolset for managing your BlackBerry(tm) device. (BlackBerry
59 is a registered trademark of Research in Motion Limited.)
61 This package contains the library files, license agreement, README file,
62 and most other assorted documentation common to all sub-packages. You most
63 likely want to also install barry-util and barry-gui.
66 %package -n libbarry-devel
67 Summary: BlackBerry(tm) Desktop for Linux - libbarry libraries
68 Group: Development/Libraries
69 Requires: libbarry0 boost-devel
71 %description -n libbarry-devel
72 Barry is a desktop toolset for managing your BlackBerry(tm) device. (BlackBerry
73 is a registered trademark of Research in Motion Limited.)
75 This package contains the development library files for Barry, libbarry.
78 %package util
79 Summary: BlackBerry(tm) Desktop for Linux - bcharge, btool, breset, bio and others
80 Group: Applications/Productivity
81 Requires: libbarry0 fuse
82 Conflicts: barry-bcharge
84 %description util
85 Barry is a desktop toolset for managing your BlackBerry(tm) device. (BlackBerry
86 is a registered trademark of Research in Motion Limited.)
88 This package contains the commandline tools bcharge, btool, breset, bio and
89 others which will enable you to charge your device with a proper 500mA
90 and be able to access the data on the device in many ways.
93 %if %{with_gui}
94 %package gui
95 Summary: BlackBerry(tm) Desktop for Linux - bcharge, btool, breset and others
96 Group: Applications/Productivity
97 Requires: libbarry0 gtkmm24 libglademm24 libtar
98 BuildRequires: gtkmm24-devel libglademm24-devel libtar-devel
100 %description gui
101 Barry is a desktop toolset for managing your BlackBerry(tm) device. (BlackBerry
102 is a registered trademark of Research in Motion Limited.)
104 This package contains the GUI applications built on top of libbarry.
105 %endif
107 # opensync 0.2x
108 %if %{with_opensync}
109 %package opensync
110 Summary: BlackBerry(tm) Desktop for Linux - opensync plugin
111 Group: Applications/Productivity
112 Requires: libbarry0, libopensync >= 0.22
113 BuildRequires: libopensync-devel
115 %description opensync
116 Barry is a desktop toolset for managing your BlackBerry(tm) device. (BlackBerry
117 is a registered trademark of Research in Motion Limited.)
119 This package contains the opensync plugin.
120 %endif
122 # opensync 0.4x
123 %if %{with_opensync4x}
124 %package opensync4x
125 Summary: BlackBerry(tm) Desktop for Linux - opensync 0.4x plugin
126 Group: Applications/Productivity
127 Requires: libbarry0, libopensync >= 0.39
128 BuildRequires: libopensync-devel
130 %description opensync4x
131 Barry is a desktop toolset for managing your BlackBerry(tm) device. (BlackBerry
132 is a registered trademark of Research in Motion Limited.)
134 This package contains the opensync 0.4x plugin.
135 %endif
137 # desktop tree
138 %if %{with_desktop}
139 %package desktop
140 Summary: BlackBerry(tm) Desktop Panel GUI for Linux
141 Group: Applications/Productivity
142 Requires: libbarry0, libopensync
143 BuildRequires: wxGTK-devel
145 %description desktop
146 Barry is a desktop toolset for managing your BlackBerry(tm) device. (BlackBerry
147 is a registered trademark of Research in Motion Limited.)
149 This package contains the desktop panel GUI.
150 %endif
152 %prep
153 %setup -q
155 %build
156 # some systems have an rpath checker, and need their own versions of
157 # configure built on the same system in order to pass... in particular,
158 # Fedora 14's 64bit version needs its own configure, for some reason,
159 # in order to recognize that /usr/lib64 is a system path and therefore
160 # there is no reason to use an rpath... unfortunately, configure's
161 # --disable-rpath option seems to have no effect whatsoever. :-(
162 %if "%{?_lib}" == "lib64"
163 ./buildgen.sh cleanall
164 ./buildgen.sh
165 %endif
167 # Generate configure if it does not exist already (for binary-meta)
168 if [ ! -f ./configure ] ; then
169 ./buildgen.sh
172 # setup the environment if there are additions (for binary-meta)
173 export ORIG_PKG_CONFIG_PATH="$PKG_CONFIG_PATH"
174 if [ -n "$ADD_TO_PKG_CONFIG_PATH" ] ; then
175 export PKG_CONFIG_PATH="$ADD_TO_PKG_CONFIG_PATH:$ORIG_PKG_CONFIG_PATH"
179 # main tree
180 %{configure} --enable-boost --enable-nls --with-zlib --with-libusb --enable-rpathhack
181 %{__make} %{?_smp_mflags}
183 # gui tree
184 %if %{with_gui}
185 cd gui/
186 %{configure} PKG_CONFIG_PATH="..:$PKG_CONFIG_PATH" CXXFLAGS="-I../.." LDFLAGS="-L../../src" --enable-nls --enable-rpathhack
187 %{__make} %{?_smp_mflags}
188 cd ../
189 %endif
191 # opensync tree
192 %if %{with_opensync}
193 # if there is a special pkgconfig for opensync 0.2x, use it
194 if [ -n "$OSYNC2X_PKG_CONFIG_PATH" ] ; then
195 export PKG_CONFIG_PATH="$OSYNC2X_PKG_CONFIG_PATH:$ORIG_PKG_CONFIG_PATH"
197 cd opensync-plugin/
198 %{configure} PKG_CONFIG_PATH="..:$PKG_CONFIG_PATH" CXXFLAGS="-I../.." LDFLAGS="-L../../src" --enable-nls --enable-rpathhack
199 %{__make} %{?_smp_mflags}
200 cd ../
201 %endif
203 # opensync4x tree
204 %if %{with_opensync4x}
205 # if there is a special pkgconfig for opensync 0.4x, use it
206 if [ -n "$OSYNC4X_PKG_CONFIG_PATH" ] ; then
207 export PKG_CONFIG_PATH="$OSYNC4X_PKG_CONFIG_PATH:$ORIG_PKG_CONFIG_PATH"
209 cd opensync-plugin-0.4x/
210 %{configure} PKG_CONFIG_PATH="..:$PKG_CONFIG_PATH" CXXFLAGS="-I../.." LDFLAGS="-L../../src" --enable-nls --enable-rpathhack
211 %{__make} %{?_smp_mflags}
212 cd ../
213 %endif
215 # desktop tree
216 %if %{with_desktop}
217 # if there is a special pkgconfig for both opensync 0.4x and 0.2x, use it
218 if [ -n "$OSYNCBOTH_PKG_CONFIG_PATH" ] ; then
219 export PKG_CONFIG_PATH="$OSYNCBOTH_PKG_CONFIG_PATH:$ORIG_PKG_CONFIG_PATH"
221 cd desktop/
222 %{configure} PKG_CONFIG_PATH="..:$PKG_CONFIG_PATH" CXXFLAGS="-I../.." LDFLAGS="-L../../src" --enable-nls --enable-rpathhack
223 %{__make} %{?_smp_mflags}
224 cd ../
225 %endif
227 %install
228 # main tree
229 %{__make} DESTDIR=%{buildroot} install
230 # delete some test-only programs
231 %{__rm} -f %{buildroot}%{_bindir}/bdptest
232 %{__rm} -f %{buildroot}%{_bindir}/bjvmdebug
233 # delete the .la files
234 %{__rm} -f %{buildroot}%{_libdir}/*.la
235 # proceed as usual...
236 %{__mkdir_p} %{buildroot}%{_sysconfdir}/udev/rules.d
237 %{__cp} udev/10-blackberry.rules %{buildroot}%{_sysconfdir}/udev/rules.d/
238 %if %{use_69_rules}
239 %{__cp} udev/69-blackberry.rules %{buildroot}%{_sysconfdir}/udev/rules.d/
240 %else
241 %{__cp} udev/99-blackberry-perms.rules %{buildroot}%{_sysconfdir}/udev/rules.d/
242 %endif
243 %{__mkdir_p} %{buildroot}%{_sysconfdir}/modprobe.d
244 %{__cp} modprobe/blacklist-berry_charge.conf %{buildroot}%{_sysconfdir}/modprobe.d/
245 %{__mkdir_p} %{buildroot}%{_sysconfdir}/ppp/peers
246 %{__cp} ppp/barry-rogers %{buildroot}%{_sysconfdir}/ppp/peers/
247 %{__cp} ppp/barry-minimal %{buildroot}%{_sysconfdir}/ppp/peers/
248 %{__cp} ppp/barry-verizon %{buildroot}%{_sysconfdir}/ppp/peers/
249 %{__cp} ppp/barry-sprint %{buildroot}%{_sysconfdir}/ppp/peers/
250 %{__cp} ppp/barry-telus %{buildroot}%{_sysconfdir}/ppp/peers/
251 %{__cp} ppp/barry-o2ireland %{buildroot}%{_sysconfdir}/ppp/peers/
252 %{__cp} ppp/barry-tmobileus %{buildroot}%{_sysconfdir}/ppp/peers/
253 %{__cp} ppp/barry-att_cingular %{buildroot}%{_sysconfdir}/ppp/peers/
254 %{__cp} ppp/barry-chinamobile %{buildroot}%{_sysconfdir}/ppp/peers/
255 %{__cp} ppp/barry-kpn %{buildroot}%{_sysconfdir}/ppp/peers/
256 %{__cp} ppp/barry-orange-spain %{buildroot}%{_sysconfdir}/ppp/peers/
257 %{__cp} ppp/barry-orangeuk %{buildroot}%{_sysconfdir}/ppp/peers/
258 %{__cp} ppp/barry-mts %{buildroot}%{_sysconfdir}/ppp/peers/
259 %{__cp} ppp/barry-optus-au %{buildroot}%{_sysconfdir}/ppp/peers/
260 %{__cp} ppp/barry-vodafone-au %{buildroot}%{_sysconfdir}/ppp/peers/
261 %{__mkdir_p} %{buildroot}%{_sysconfdir}/chatscripts
262 %{__cp} ppp/barry-rogers.chat %{buildroot}%{_sysconfdir}/chatscripts/
263 %{__cp} ppp/barry-minimal.chat %{buildroot}%{_sysconfdir}/chatscripts/
264 %{__cp} ppp/barry-verizon.chat %{buildroot}%{_sysconfdir}/chatscripts/
265 %{__cp} ppp/barry-sprint.chat %{buildroot}%{_sysconfdir}/chatscripts/
266 %{__cp} ppp/barry-telus.chat %{buildroot}%{_sysconfdir}/chatscripts/
267 %{__cp} ppp/barry-o2ireland.chat %{buildroot}%{_sysconfdir}/chatscripts/
268 %{__cp} ppp/barry-tmobileus.chat %{buildroot}%{_sysconfdir}/chatscripts/
269 %{__cp} ppp/barry-att_cingular.chat %{buildroot}%{_sysconfdir}/chatscripts/
270 %{__cp} ppp/barry-chinamobile.chat %{buildroot}%{_sysconfdir}/chatscripts/
271 %{__cp} ppp/barry-kpn.chat %{buildroot}%{_sysconfdir}/chatscripts/
272 %{__cp} ppp/barry-orange-spain.chat %{buildroot}%{_sysconfdir}/chatscripts/
273 %{__cp} ppp/barry-orangeuk.chat %{buildroot}%{_sysconfdir}/chatscripts/
274 %{__cp} ppp/barry-mts.chat %{buildroot}%{_sysconfdir}/chatscripts/
275 %{__cp} ppp/barry-optus-au.chat %{buildroot}%{_sysconfdir}/chatscripts/
276 %{__cp} ppp/barry-vodafone-au.chat %{buildroot}%{_sysconfdir}/chatscripts/
277 # Install hal fdi config
278 %{__mkdir_p} %{buildroot}%{_datadir}/hal/fdi/information/10freedesktop
279 %{__mkdir_p} %{buildroot}%{_datadir}/hal/fdi/policy/10osvendor
280 %{__cp} hal/fdi/information/10freedesktop/10-blackberry.fdi %{buildroot}%{_datadir}/hal/fdi/information/10freedesktop
281 %{__cp} hal/fdi/policy/10osvendor/19-blackberry-acl.fdi %{buildroot}%{_datadir}/hal/fdi/policy/10osvendor
282 # Install hal support script
283 %{__mkdir_p} %{buildroot}%{_bindir}
284 %{__cp} hal/hal-blackberry %{buildroot}%{_bindir}
285 # Install bash completion scripts
286 %{__mkdir_p} %{buildroot}%{_sysconfdir}/bash_completion.d
287 %{__cp} bash/bjavaloader %{buildroot}%{_sysconfdir}/bash_completion.d
288 %{__cp} bash/btool %{buildroot}%{_sysconfdir}/bash_completion.d
290 # gui tree
291 %if %{with_gui}
292 cd gui/
293 %{__make} DESTDIR=%{buildroot} install
294 # Install barry logo icon
295 cd ../
296 %{__mkdir_p} %{buildroot}%{_datadir}/pixmaps
297 %{__cp} logo/barry_logo_icon.png %{buildroot}%{_datadir}/pixmaps
298 desktop-file-install --vendor netdirect \
299 --dir %{buildroot}%{_datadir}/applications \
300 menu/barrybackup.desktop
301 %endif
303 # opensync tree
304 %if %{with_opensync}
305 cd opensync-plugin/
306 %{__make} DESTDIR=%{buildroot} install
307 # remove .la files
308 %{__rm} -f %{buildroot}%{_libdir}/opensync/plugins/*.la
309 cd ../
310 %endif
312 # opensync4x tree
313 %if %{with_opensync4x}
314 cd opensync-plugin-0.4x/
315 %{__make} DESTDIR=%{buildroot} install
316 # remove .la files
317 %{__rm} -f %{buildroot}%{_libdir}/libopensync1/plugins/*.la
318 cd ../
319 %endif
321 # desktop tree
322 %if %{with_desktop}
323 cd desktop/
324 %{__make} DESTDIR=%{buildroot} install
325 # remove .la files
326 %{__rm} -f %{buildroot}%{_libdir}/*.la
327 cd ../
328 %{__cp} logo/barry_logo_icon.png %{buildroot}%{_datadir}/pixmaps/barry_desktop_icon.png
329 desktop-file-install --vendor netdirect \
330 --dir %{buildroot}%{_datadir}/applications \
331 menu/barrydesktop.desktop
332 %endif
334 %files -n libbarry0
335 %defattr(-,root,root)
336 %attr(-,root,root) %{_libdir}/libbarry.so.*
337 %attr(-,root,root) %{_libdir}/libbarrydp.so.*
338 %attr(-,root,root) %{_libdir}/libbarryjdwp.so.*
339 %attr(-,root,root) %{_libdir}/libbarrysync.so.*
340 %attr(-,root,root) %{_libdir}/libbarrybackup.so.*
341 %attr(-,root,root) %{_libdir}/libbarryalx.so.*
342 %doc AUTHORS ChangeLog COPYING NEWS README
344 %files -n libbarry-devel
345 %defattr(-,root,root)
346 %attr(0644,root,root) %{_includedir}/barry*/barry/*
347 %attr(0644,root,root) %{_libdir}/libbarry.a
348 %attr(0644,root,root) %{_libdir}/libbarry.so
349 %attr(0644,root,root) %{_libdir}/libbarrydp.a
350 %attr(0644,root,root) %{_libdir}/libbarrydp.so
351 %attr(0644,root,root) %{_libdir}/libbarryjdwp.a
352 %attr(0644,root,root) %{_libdir}/libbarryjdwp.so
353 %attr(0644,root,root) %{_libdir}/libbarrysync.a
354 %attr(0644,root,root) %{_libdir}/libbarrysync.so
355 %attr(0644,root,root) %{_libdir}/libbarrybackup.a
356 %attr(0644,root,root) %{_libdir}/libbarrybackup.so
357 %attr(0644,root,root) %{_libdir}/libbarryalx.a
358 %attr(0644,root,root) %{_libdir}/libbarryalx.so
359 %attr(0644,root,root) %{_libdir}/pkgconfig/*.pc
360 %doc COPYING TODO doc/* examples/*.cc
362 %files util
363 %defattr(-,root,root)
364 %attr(0755,root,root) %{_sbindir}/bcharge
365 %attr(0755,root,root) %{_sbindir}/breset
366 %attr(0755,root,root) %{_sbindir}/pppob
367 %attr(0755,root,root) %{_bindir}/btool
368 %attr(0755,root,root) %{_bindir}/bwatch
369 %attr(0755,root,root) %{_bindir}/bio
370 %attr(0755,root,root) %{_bindir}/btardump
371 %attr(0755,root,root) %{_bindir}/bfuse
372 %attr(0755,root,root) %{_bindir}/bjavaloader
373 %attr(0755,root,root) %{_bindir}/balxparse
374 %attr(0755,root,root) %{_bindir}/bjdwp
375 %attr(0755,root,root) %{_bindir}/brawchannel
376 %attr(0755,root,root) %{_bindir}/bs11nread
377 %attr(0755,root,root) %{_bindir}/bidentify
378 %attr(0755,root,root) %{_bindir}/brecsum
379 %attr(0755,root,root) %{_bindir}/upldif
380 %attr(0755,root,root) %{_bindir}/bktrans
381 %attr(0755,root,root) %{_bindir}/btranslate
382 %attr(0755,root,root) %{_bindir}/brimtrans
383 %attr(0755,root,root) %{_bindir}/hal-blackberry
384 %attr(0644,root,root) %{_mandir}/man1/btool*
385 %attr(0644,root,root) %{_mandir}/man1/bwatch*
386 %attr(0644,root,root) %{_mandir}/man1/bio*
387 %attr(0644,root,root) %{_mandir}/man1/btardump*
388 %attr(0644,root,root) %{_mandir}/man1/bfuse*
389 %attr(0644,root,root) %{_mandir}/man1/bjavaloader*
390 %attr(0644,root,root) %{_mandir}/man1/balxparse*
391 %attr(0644,root,root) %{_mandir}/man1/bjdwp*
392 %attr(0644,root,root) %{_mandir}/man1/brawchannel*
393 %attr(0644,root,root) %{_mandir}/man1/bs11nread*
394 %attr(0644,root,root) %{_mandir}/man1/bidentify*
395 %attr(0644,root,root) %{_mandir}/man1/bcharge*
396 %attr(0644,root,root) %{_mandir}/man1/pppob*
397 %attr(0644,root,root) %{_mandir}/man1/brecsum*
398 %attr(0644,root,root) %{_mandir}/man1/breset*
399 %attr(0644,root,root) %{_mandir}/man1/upldif*
400 %attr(0644,root,root) %{_datadir}/locale/*
401 %attr(0644,root,root) %{_datadir}/hal/fdi/information/10freedesktop/10-blackberry.fdi
402 %attr(0644,root,root) %{_datadir}/hal/fdi/policy/10osvendor/19-blackberry-acl.fdi
403 %attr(0644,root,root) %config %{_sysconfdir}/udev/rules.d/*
404 %attr(0644,root,root) %config %{_sysconfdir}/modprobe.d/blacklist-berry_charge.conf
405 %attr(0644,root,root) %config %{_sysconfdir}/ppp/peers/barry-rogers
406 %attr(0644,root,root) %config %{_sysconfdir}/ppp/peers/barry-minimal
407 %attr(0644,root,root) %config %{_sysconfdir}/ppp/peers/barry-verizon
408 %attr(0644,root,root) %config %{_sysconfdir}/ppp/peers/barry-sprint
409 %attr(0644,root,root) %config %{_sysconfdir}/ppp/peers/barry-telus
410 %attr(0644,root,root) %config %{_sysconfdir}/ppp/peers/barry-o2ireland
411 %attr(0644,root,root) %config %{_sysconfdir}/ppp/peers/barry-tmobileus
412 %attr(0644,root,root) %config %{_sysconfdir}/ppp/peers/barry-att_cingular
413 %attr(0644,root,root) %config %{_sysconfdir}/ppp/peers/barry-chinamobile
414 %attr(0644,root,root) %config %{_sysconfdir}/ppp/peers/barry-kpn
415 %attr(0644,root,root) %config %{_sysconfdir}/ppp/peers/barry-orange-spain
416 %attr(0644,root,root) %config %{_sysconfdir}/ppp/peers/barry-orangeuk
417 %attr(0644,root,root) %config %{_sysconfdir}/ppp/peers/barry-mts
418 %attr(0644,root,root) %config %{_sysconfdir}/ppp/peers/barry-optus-au
419 %attr(0644,root,root) %config %{_sysconfdir}/ppp/peers/barry-vodafone-au
420 %attr(0640,root,root) %config %{_sysconfdir}/chatscripts/barry-rogers.chat
421 %attr(0640,root,root) %config %{_sysconfdir}/chatscripts/barry-minimal.chat
422 %attr(0640,root,root) %config %{_sysconfdir}/chatscripts/barry-verizon.chat
423 %attr(0640,root,root) %config %{_sysconfdir}/chatscripts/barry-sprint.chat
424 %attr(0640,root,root) %config %{_sysconfdir}/chatscripts/barry-telus.chat
425 %attr(0640,root,root) %config %{_sysconfdir}/chatscripts/barry-o2ireland.chat
426 %attr(0640,root,root) %config %{_sysconfdir}/chatscripts/barry-tmobileus.chat
427 %attr(0640,root,root) %config %{_sysconfdir}/chatscripts/barry-att_cingular.chat
428 %attr(0640,root,root) %config %{_sysconfdir}/chatscripts/barry-chinamobile.chat
429 %attr(0640,root,root) %config %{_sysconfdir}/chatscripts/barry-kpn.chat
430 %attr(0640,root,root) %config %{_sysconfdir}/chatscripts/barry-orange-spain.chat
431 %attr(0640,root,root) %config %{_sysconfdir}/chatscripts/barry-orangeuk.chat
432 %attr(0640,root,root) %config %{_sysconfdir}/chatscripts/barry-mts.chat
433 %attr(0640,root,root) %config %{_sysconfdir}/chatscripts/barry-optus-au.chat
434 %attr(0640,root,root) %config %{_sysconfdir}/chatscripts/barry-vodafone-au.chat
435 %attr(0640,root,root) %config %{_sysconfdir}/bash_completion.d/bjavaloader
436 %attr(0640,root,root) %config %{_sysconfdir}/bash_completion.d/btool
437 %doc COPYING
438 %doc zsh
439 %doc ppp/README
441 %if %{with_gui}
442 %files gui
443 %defattr(-,root,root)
444 %attr(0755,root,root) %{_bindir}/barrybackup
445 %attr(0644,root,root) %{_datadir}/barry/glade/*.glade
446 %attr(0644,root,root) %{_datadir}/pixmaps/barry_logo_icon.png
447 %attr(0644,root,root) %{_datadir}/applications/*barrybackup.desktop
448 %attr(0644,root,root) %{_mandir}/man1/barrybackup*
449 %doc COPYING
450 %endif
452 %if %{with_opensync}
453 %files opensync
454 %defattr(-,root,root)
455 %attr(0755,root,root) %{_libdir}/opensync/plugins/barry_sync.so
456 %attr(0644,root,root) %{_datadir}/opensync/defaults/barry-sync
457 %doc COPYING
458 %endif
460 %if %{with_opensync4x}
461 %files opensync4x
462 %defattr(-,root,root)
463 %attr(0755,root,root) %{_libdir}/libopensync1/plugins/barry_sync.so
464 %attr(0644,root,root) %{_datadir}/libopensync1/defaults/barry-sync
465 %doc COPYING
466 %endif
468 # desktop tree
469 %if %{with_desktop}
470 %files desktop
471 %defattr(-,root,root)
472 %attr(0755,root,root) %{_bindir}/barrydesktop
473 %attr(0755,root,root) %{_bindir}/bsyncjail
474 %attr(0755,root,root) %{_bindir}/bsynccl
475 %attr(0644,root,root) %{_datadir}/barry/desktop/0.22/*
476 %attr(0644,root,root) %{_datadir}/barry/desktop/0.40/*
477 %attr(0644,root,root) %{_datadir}/barry/desktop/images/*.png
478 %attr(0644,root,root) %{_datadir}/pixmaps/barry_desktop_icon.png
479 %attr(0644,root,root) %{_datadir}/applications/*barrydesktop.desktop
480 %attr(0644,root,root) %{_mandir}/man1/barrydesktop*
481 %attr(-,root,root) %{_libdir}/libosyncwrap.so.*
482 %attr(-,root,root) %{_libdir}/libosyncwrap.a
483 %attr(-,root,root) %{_libdir}/libosyncwrap.so
484 %attr(0644,root,root) %{_includedir}/barry*/osyncwrap/*
485 %doc COPYING
486 %endif
488 %clean
489 [ "%{buildroot}" != "/" ] && %{__rm} -rf %{buildroot}
490 [ "%{barryroot}" != "/" ] && %{__rm} -rf %{barryroot}
492 %post -n libbarry0
493 /sbin/ldconfig
495 %postun -n libbarry0
496 /sbin/ldconfig
498 %changelog
499 * Mon Aug 8 2011 Chris Frey <cdfrey@foursquare.net> 0.18.0-0
500 - version bump
501 - removed dependency of libbarry-devel on libusb(-devel)
502 - added osyncwrap headers
503 - removed opensuse special cases
504 - back to optional --with behaviour
505 - added opensync 0.4x package support
506 - removed .la files
507 - split up dev libraries a little better (-devel should have the dev libs)
508 - put desktop library in desktop package
509 - added orangeuk and mts ppp chatscript files
510 - added bwatch
512 * Fri May 28 2010 Chris Frey <cdfrey@foursquare.net> 0.17.0-0
513 - version bump
514 - added NLS support
515 - cleaned up conditionals
516 - added Fedora 13 support
517 - added new ppp chat scripts for Orange Spain, Optus and Vodafone AU
518 - added copy of barry-sprint as barry-telus
519 - added brawchannel, btardump, bio, and balxparse
520 - added desktop support
521 - cleaned up desktop variables
523 * Sat Sep 29 2009 Chris Frey <cdfrey@foursquare.net> 0.16-0
524 - version bump
525 - added new ppp chat script for KPN Nederland
526 - using new udev rules set
527 - added bjdwp and manpage, and removed some test-only programs
528 - added bash and zsh completion scripts
529 - added .desktop file and icon for barrybackup
531 * Fri Apr 10 2009 Chris Frey <cdfrey@foursquare.net> 0.15-0
532 - version bump
533 - added HAL FDI scripts
534 - added bjavaloader and bfuse
535 - updated for udev directory reorganization in Barry source tree
536 - added zlib-devel to BuildRequires list
537 - added brimtrans
539 * Wed Sep 24 2008 Chris Frey <cdfrey@foursquare.net> 0.14-0
540 - version bump
541 - added new ppp chat script for T-Mobile US
542 - renamed libbarry to libbarry0
544 * Thu May 29 2008 Chris Frey <cdfrey@foursquare.net> 0.13-1
545 - version bump
546 - added brecsum
547 - added ppp options and chat scripts
548 - added manpages for pppob, brecsum, breset, upldif, barrybackup
549 - spec file now assumes gui and opensync, with conditional checks depending on host
551 * Fri Dec 07 2007 Chris Frey <cdfrey@foursquare.net> 0.12-1
552 - version bump
554 * Fri Nov 30 2007 Chris Frey <cdfrey@foursquare.net> 0.11-1
555 - version bump
557 * Fri Nov 30 2007 Chris Frey <cdfrey@foursquare.net> 0.10-1
558 - version bump
559 - removed ktrans and translate from rpm package
560 - added bidentify
562 * Thu Aug 09 2007 Chris Frey <cdfrey@foursquare.net> 0.9-1
563 - version bump
565 * Fri Aug 03 2007 Chris Frey <cdfrey@foursquare.net> 0.8-1
566 - version bump
567 - changed tarball to bz2
569 * Tue May 01 2007 Chris Frey <cdfrey@foursquare.net> 0.7-2
570 - added pppob to utils
572 * Thu Mar 08 2007 Chris Frey <cdfrey@foursquare.net> 0.7-1
573 - removed barry base package that only contained docs, and put docs in libbarry*
574 - changed barrybackup reference to barry-gui
575 - removed the patch step, as version 0.7 shouldn't need it
576 - added license file to each package
578 * Sun Mar 04 2007 Troy Engel <tengel@users.sourceforge.net> 0.6-1
579 - initial build
580 - adding udev and console perms patch for raw 0.6