Really release 0.47
[awl.git] / debian / rules
blobfcd3c58770066e9d28f512f12df74bedd583c206
1 #!/usr/bin/make -f
3 # rules for AWL
5 # This file allows you to build any of the binary packages independantly, via binary-<package> targets.
7 # Uncomment this to turn on verbose mode.
8 #export DH_VERBOSE=1
10 # This has to be exported to make some magic below work.
11 export DH_OPTIONS
13 build: build-stamp
14 build-stamp:
15 dh_testdir
16 $(MAKE)
17 touch build-stamp
19 clean:
20 dh_testdir
21 dh_testroot
22 rm -f build-stamp
24 $(MAKE) clean
25 -rm -f build
27 dh_clean
29 install: DH_OPTIONS=
30 install: build
31 dh_testdir
32 dh_testroot
33 dh_prep
34 dh_installdirs
36 dh_install
38 # This single target is used to build all the packages, all at once, or
39 # one at a time. So keep in mind: any options passed to commands here will
40 # affect _all_ packages. Anything you want to only affect one package
41 # should be put in another target, such as the install target.
42 binary-common:
43 dh_testdir
44 dh_testroot
45 dh_installchangelogs
46 dh_installdocs
47 # dh_installexamples
48 # dh_installmenu
49 # dh_installdebconf
50 # dh_installlogrotate
51 # dh_installemacsen
52 # dh_installcatalogs
53 # dh_installpam
54 # dh_installmime
55 # dh_installinit
56 # dh_installman
57 # dh_installcron
58 # dh_installinfo
59 # dh_installwm
60 # dh_installudev
61 # dh_lintian
62 # dh_undocumented
63 # dh_strip
64 # dh_link
65 dh_compress --exclude=.js
66 dh_fixperms
67 # dh_perl
68 # dh_python
69 # dh_makeshlibs
70 dh_installdeb
71 # dh_shlibdeps
72 dh_gencontrol
73 dh_md5sums
74 dh_builddeb
76 # Build architecture independant packages using the common target.
77 binary-indep: build install
78 $(MAKE) -f debian/rules DH_OPTIONS=-i binary-common
80 # Build architecture dependant packages using the common target.
81 binary-arch: build install
83 # Any other binary targets build just one binary package at a time.
84 binary-%: build install
85 make -f debian/rules binary-common DH_OPTIONS=-p$*
87 binary: binary-indep binary-arch
89 .PHONY: build clean binary-indep binary-arch binary-common binary install