pciutils: fix HOST detection
[avatt.git] / package / pciutils / pciutils.mk
blob0d8155f4078033722cf6119a462a015b0f023a2a
1 #############################################################
3 # pciutils
5 #############################################################
6 PCIUTILS_VERSION:=3.0.1
7 PCIUTILS_SOURCE:=pciutils-$(PCIUTILS_VERSION).tar.gz
8 PCIUTILS_CAT:=$(ZCAT)
9 PCIUTILS_SITE:=ftp://atrey.karlin.mff.cuni.cz/pub/linux/pci
10 PCIUTILS_DIR:=$(BUILD_DIR)/pciutils-$(PCIUTILS_VERSION)
12 # Yet more targets...
13 PCIIDS_SITE:=http://pciids.sourceforge.net/
14 PCIIDS_SOURCE:=pci.ids.bz2
15 PCIIDS_CAT:=$(BZCAT)
17 ifeq ($(BR2_PACKAGE_ZLIB),y)
18 PCIUTILS_HAVE_ZLIB=yes
19 PCIIDS_FILE=pci.ids.gz
20 PCIIDS_COMPRESSOR=gzip -9 -c
21 else
22 PCIUTILS_HAVE_ZLIB=no
23 PCIIDS_FILE=pci.ids
24 PCIIDS_COMPRESSOR=cat
25 endif
27 $(DL_DIR)/$(PCIUTILS_SOURCE):
28 $(call DOWNLOAD,$(PCIUTILS_SITE),$(PCIUTILS_SOURCE))
30 $(DL_DIR)/$(PCIIDS_SOURCE):
31 $(call DOWNLOAD,$(PCIIDS_SITE),$(PCIIDS_SOURCE))
33 $(PCIUTILS_DIR)/.unpacked: $(DL_DIR)/$(PCIUTILS_SOURCE) $(DL_DIR)/$(PCIIDS_SOURCE)
34 $(PCIUTILS_CAT) $(DL_DIR)/$(PCIUTILS_SOURCE) | tar -C $(BUILD_DIR) $(TAR_OPTIONS) -
35 $(PCIIDS_CAT) $(DL_DIR)/$(PCIIDS_SOURCE) | $(PCIIDS_COMPRESSOR) > $(PCIUTILS_DIR)/$(PCIIDS_FILE)
36 toolchain/patch-kernel.sh $(PCIUTILS_DIR) package/pciutils pciutils-$(PCIUTILS_VERSION)\*.patch
37 #$(CONFIG_UPDATE) $(@D)
38 $(SED) 's/uname -s/echo Linux/' \
39 -e 's/uname -r/echo $(LINUX_HEADERS_VERSION)/' \
40 $(PCIUTILS_DIR)/lib/configure
41 touch $@
43 $(PCIUTILS_DIR)/.compiled: $(PCIUTILS_DIR)/.unpacked
44 $(MAKE1) CC="$(TARGET_CC)" OPT="$(TARGET_CFLAGS)" RANLIB=$(TARGET_RANLIB) AR=$(TARGET_AR) -C $(PCIUTILS_DIR) \
45 SHAREDIR="/usr/share/misc" \
46 ZLIB=$(PCIUTILS_HAVE_ZLIB) \
47 HOST=$(KERNEL_ARCH)-linux \
48 PREFIX=/usr
49 touch $@
51 $(TARGET_DIR)/sbin/lspci: $(PCIUTILS_DIR)/.compiled
52 $(INSTALL) $(PCIUTILS_DIR)/lspci $(TARGET_DIR)/sbin/lspci
53 $(STRIPCMD) $(STRIP_STRIP_ALL) $@
55 $(TARGET_DIR)/sbin/setpci: $(PCIUTILS_DIR)/.compiled
56 $(INSTALL) $(PCIUTILS_DIR)/setpci $(TARGET_DIR)/sbin/setpci
57 $(STRIPCMD) $(STRIP_STRIP_ALL) $@
59 $(TARGET_DIR)/usr/share/misc/$(PCIIDS_FILE): $(PCIUTILS_DIR)/.unpacked
60 $(INSTALL) -D $(PCIUTILS_DIR)/$(PCIIDS_FILE) $@
62 pciutils: uclibc $(if $(BR2_PACKAGE_ZLIB),zlib) $(TARGET_DIR)/sbin/setpci $(TARGET_DIR)/sbin/lspci $(TARGET_DIR)/usr/share/misc/$(PCIIDS_FILE)
64 pciutils-source: $(DL_DIR)/$(PCIUTILS_SOURCE) $(DL_DIR)/$(PCIIDS_SOURCE)
66 pciutils-clean:
67 -$(MAKE) -C $(PCIUTILS_DIR) clean
68 rm -f $(TARGET_DIR)/sbin/lspci $(TARGET_DIR)/sbin/setpci $(TARGET_DIR)/usr/share/misc/pci.ids*
70 pciutils-dirclean:
71 rm -rf $(PCIUTILS_DIR)
73 #############################################################
75 # Toplevel Makefile options
77 #############################################################
78 ifeq ($(BR2_PACKAGE_PCIUTILS),y)
79 TARGETS+=pciutils
80 endif