aur-build.1: document XDG_RUNTIME_DIR wrapper script
[aurutils.git] / makepkg / PKGBUILD
blobe66889e83b6014ee0c96e8a671296e9586d41013
1 # Maintainer: Alad Wenter <https://github.com/AladW>
2 pkgname=aurutils-git
3 pkgver=3.0.0rc.r7.gc91de35
4 pkgrel=1
5 pkgdesc='helper tools for the arch user repository'
6 url='https://github.com/AladW/aurutils'
7 arch=('any')
8 license=('custom:ISC')
9 source=('git+https://github.com/AladW/aurutils')
10 changelog=aurutils.changelog
11 sha256sums=('SKIP')
12 conflicts=('aurutils')
13 provides=("aurutils=${pkgver%%.r*}")
14 depends=('git' 'jq' 'pacutils' 'curl')
15 makedepends=('git')
16 optdepends=('bash-completion: bash completion'
17             'zsh: zsh completion'
18             'devtools: aur-chroot'
19             'vifm: default pager')
21 pkgver() {
22     cd aurutils
23     git describe --long --tags | sed 's/\([^-]*-g\)/r\1/; s/-/./g'
26 build() {
27     cd aurutils
28     make DESTDIR="$pkgdir"
31 package() {
32     cd aurutils
33     make DESTDIR="$pkgdir" install