archrelease: copy trunk to extra-x86_64
[arch-packages.git] / step / trunk / PKGBUILD
blobb3ba33c894a36bd05489824ba17e575b85fc6827
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
2 # Maintainer: Antonio Rojas <arojas@archlinux.org>
3 # Contributor: Andrea Scarpino <andrea@archlinux.org>
5 pkgname=step
6 pkgver=23.04.1
7 pkgrel=1
8 pkgdesc='Interactive Physical Simulator'
9 url='https://apps.kde.org/step/'
10 arch=(x86_64)
11 license=(GPL LGPL FDL)
12 groups=(kde-applications kde-education)
13 depends=(libqalculate gsl knewstuff kplotting hicolor-icon-theme)
14 makedepends=(extra-cmake-modules kdoctools eigen qt5-tools python)
15 source=(https://download.kde.org/stable/release-service/$pkgver/src/$pkgname-$pkgver.tar.xz{,.sig})
16 sha256sums=('2e495bfa2bda484b28ca83a7f6209070a1c88308d3a515110d208c36c6cc8ebd'
17             'SKIP')
18 validpgpkeys=(CA262C6C83DE4D2FB28A332A3A6A4DB839EAA6D7  # Albert Astals Cid <aacid@kde.org>
19               F23275E4BF10AFC1DF6914A6DBD2CE893E2D1C87  # Christoph Feck <cfeck@kde.org>
20               D81C0CB38EB725EF6691C385BB463350D6EF31EF) # Heiko Becker <heiko.becker@kde.org>
22 build() {
23   cmake -B build -S $pkgname-$pkgver \
24     -DBUILD_TESTING=OFF
25   cmake --build build
28 package() {
29   DESTDIR="$pkgdir" cmake --install build