archrelease: copy trunk to extra-x86_64
[arch-packages.git] / qt6-grpc / trunk / PKGBUILD
blob329e389e0e9391fd3fa836a7b0b2f88a937b3ec1
1 # Maintainer: Antonio Rojas <arojas@archlinux.org>
2 # Maintainer: Felix Yan <felixonmars@archlinux.org>
4 pkgname=qt6-grpc
5 _qtver=6.5.0
6 pkgver=${_qtver/-/}
7 pkgrel=1
8 arch=(x86_64)
9 url='https://www.qt.io'
10 license=(GPL3 LGPL3 FDL custom)
11 pkgdesc='Provides the modules QtGrpc and QtProtobuf'
12 depends=(qt6-base grpc)
13 makedepends=(cmake ninja protobuf)
14 groups=(qt6)
15 _pkgfn=${pkgname/6-/}-everywhere-src-$_qtver
16 source=(https://download.qt.io/official_releases/qt/${pkgver%.*}/$_qtver/submodules/$_pkgfn.tar.xz)
17 sha256sums=('589f4b368c6b5df3f9049ece9f9e99a67a700f5d78a8c21a7ae3798a4ace2ff3')
19 build() {
20   cmake -B build -S $_pkgfn -G Ninja \
21     -DCMAKE_MESSAGE_LOG_LEVEL=STATUS
22   cmake --build build
25 package() {
26   DESTDIR="$pkgdir" cmake --install build
28   install -d "$pkgdir"/usr/share/licenses
29   ln -s /usr/share/licenses/qt6-base "$pkgdir"/usr/share/licenses/$pkgname