archrelease: copy trunk to extra-x86_64
[arch-packages.git] / php-xcache / trunk / PKGBUILD
blobe194cbecffe6b0e860f4dff18e24628976364764
1 # Maintainer: Pierre Schmitz <pierre@archlinux.de>
3 pkgname=php-xcache
4 pkgver=3.2.0
5 pkgrel=2
6 arch=('x86_64')
7 pkgdesc='A PHP opcode cacher'
8 url='http://xcache.lighttpd.net/'
9 depends=('php')
10 license=('custom')
11 source=("http://xcache.lighttpd.net/pub/Releases/${pkgver}/xcache-${pkgver}.tar.bz2"
12         'xcache.ini')
13 backup=('etc/php/conf.d/xcache.ini')
14 md5sums=('51bbbf533f4b476c73373f9f480f3097'
15          '8fd9ce537ada9463c4b0c042243158c0')
17 build() {
18         cd $srcdir/xcache-$pkgver
19         phpize
20         ./configure --prefix=/usr
21         make
24 check() {
25         cd $srcdir/xcache-$pkgver
26         export NO_INTERACTION=1
27         make test
28         echo
31 package() {
32         cd $srcdir/xcache-$pkgver
33         make INSTALL_ROOT=$pkgdir install
35         install -Dm644 $srcdir/xcache.ini $pkgdir/etc/php/conf.d/xcache.ini
37         install -dm755 $pkgdir/usr/share/webapps/php-xcache
38         cp -r htdocs/* $pkgdir/usr/share/webapps/php-xcache/
40         install -Dm644 COPYING $pkgdir/usr/share/licenses/php-xcache/COPYING