archrelease: copy trunk to extra-x86_64
[arch-packages.git] / gnome-video-effects / repos / extra-any / PKGBUILD
blobaf4b31fcb22ea608b0c958a5bcfbaa8a899e66f2
1 # Maintainer: Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
3 pkgname=gnome-video-effects
4 pkgver=0.5.0+r18+g5f4c801
5 pkgrel=1
6 epoch=1
7 pkgdesc="Collection of GStreamer effects for GNOME"
8 url="https://gitlab.gnome.org/GNOME/gnome-video-effects"
9 arch=(any)
10 license=(GPL2)
11 depends=(
12   frei0r-plugins
13   gst-plugins-bad
14   gst-plugins-good
16 makedepends=(
17   git
18   meson
20 _commit=5f4c801ceff9e10f7ae6c1b0b3ff907f56f945e3  # master
21 source=("git+$url.git#commit=$_commit")
22 b2sums=('SKIP')
24 pkgver() {
25   cd $pkgname
26   git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
29 prepare() {
30   cd $pkgname
33 build() {
34   arch-meson $pkgname build
35   meson compile -C build
38 check() {
39   meson test -C build --print-errorlogs
42 package() {
43   meson install -C build --destdir "$pkgdir"
46 # vim:set sw=2 sts=-1 et: