archrelease: copy trunk to extra-x86_64
[arch-packages.git] / gnome-terminal / trunk / PKGBUILD
blob1b6fb476d6e2f9fecb5633b24940be88f510e61d
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Jan de Groot <jgc@archlinux.org>
4 pkgname=gnome-terminal
5 pkgver=3.48.1
6 pkgrel=1
7 pkgdesc="The GNOME Terminal Emulator"
8 url="https://wiki.gnome.org/Apps/Terminal"
9 arch=(x86_64)
10 license=(GPL)
11 depends=(
12   gsettings-desktop-schemas
13   vte3
15 makedepends=(
16   docbook-xsl
17   git
18   gnome-shell
19   libnautilus-extension
20   meson
21   yelp-tools
23 groups=(gnome-extra)
24 _commit=1446ff0abc478bdd03c6665b718214d075729024  # tags/3.48.1^0
25 source=("git+https://gitlab.gnome.org/GNOME/gnome-terminal.git#commit=$_commit")
26 b2sums=('SKIP')
28 pkgver() {
29   cd $pkgname
30   git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
33 prepare() {
34   cd $pkgname
37 build() {
38   local meson_options=(
39     -D b_lto=false
40   )
42   arch-meson $pkgname build "${meson_options[@]}"
43   meson compile -C build
46 check() {
47   meson test -C build --print-errorlogs
50 package() {
51   meson install -C build --destdir "$pkgdir"
54 # vim:set sw=2 sts=-1 et: