archrelease: copy trunk to extra-x86_64
[arch-packages.git] / gnome-system-monitor / repos / extra-x86_64 / PKGBUILD
blob9e52462a1815f9d80777883f9e79f1959e986ec8
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Jan de Groot <jgc@archlinux.org>
4 pkgname=gnome-system-monitor
5 pkgver=44.0
6 pkgrel=1
7 pkgdesc="View current processes and monitor system state"
8 url="https://wiki.gnome.org/Apps/SystemMonitor"
9 arch=(x86_64)
10 license=(GPL)
11 depends=(
12   gtkmm3
13   libgtop
14   libhandy
15   librsvg
16   polkit
17   systemd
19 makedepends=(
20   appstream-glib
21   git
22   meson
23   yelp-tools
25 groups=(gnome)
26 _commit=e75e0f8b3162daa1f66664e4531bc717b092c164  # tags/44.0^0
27 source=("git+https://gitlab.gnome.org/GNOME/gnome-system-monitor.git#commit=$_commit")
28 b2sums=('SKIP')
30 pkgver() {
31   cd $pkgname
32   git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
35 prepare() {
36   cd $pkgname
39 build() {
40   arch-meson $pkgname build
41   meson compile -C build
44 check() {
45   meson test -C build --print-errorlogs
48 package() {
49   meson install -C build --destdir "$pkgdir"
52 # vim:set sw=2 sts=-1 et: