archrelease: copy trunk to extra-x86_64
[arch-packages.git] / avidemux / trunk / PKGBUILD
blob98fa6d1603aa2c9f217602d6655de3c4250849e3
1 # Maintainer: Levente Polyak <anthraxx[at]archlinux[dot]org>
2 # Maintainer: Eric BĂ©langer <eric@archlinux.org>
4 pkgbase=avidemux
5 pkgname=('avidemux-cli' 'avidemux-qt')
6 pkgver=2.8.1
7 pkgrel=2
8 pkgdesc='Graphical tool to edit video (filter/re-encode/split)'
9 url='http://fixounet.free.fr/avidemux/'
10 arch=('x86_64')
11 license=('GPL2')
12 makedepends=('cmake' 'libxslt' 'qt5-base' 'jack' 'libvorbis' 'libxv' 'opus' 'desktop-file-utils'
13              'alsa-lib' 'lame' 'xvidcore' 'faad2' 'faac' 'x264' 'x265' 'libsamplerate'
14              'opencore-amr' 'yasm' 'mesa' 'libvpx' 'libpulse' 'libva' 'intltool' 'sqlite'
15              'libvdpau' 'libdca' 'fribidi' 'glu' 'qt5-tools' 'twolame' 'libfdk-aac' 'libass')
16 options=('!emptydirs')
17 source=(https://downloads.sourceforge.net/avidemux/avidemux_${pkgver}.tar.gz
18         log.diff)
19 sha256sums=('77d9bdca8683ce57c192b69d207cfab7cf92a7759ce0f63fa37b5c8e42ad3da2'
20             '8b751d137037f22fd4ae6750709014bcf61269a18f1c32e1a91f481285c807aa')
21 sha512sums=('c8df5c0d7f20fd9003560dee7cc0964ba810fc2786cefd525c09fd9f740339dd92a42989938ca48c16aca778ed5bd93a56572b0c6397fe04e47225cc109e7d75'
22             'bbae5b4a549113b12e728c4c0ac8c1c92a0b7500be8dcecc791c16c9a913406feaa9f7bc477985970a920d2df391cc9392457512d84b9c4b829981cc072f2b2e')
24 prepare() {
25   cd ${pkgbase}_${pkgver}
26   patch -Np1 -i ../log.diff  # don't hide the build output
27   sed -i 's|../avidemux/qt4|../avidemux/qt4 -DLRELEASE_EXECUTABLE=/usr/bin/lrelease-qt5|' bootStrap.bash
28   sed -e 's|0.19|1.0|' -i avidemux_plugins/ADM_videoFilters6/ass/CMakeLists.txt
31 build() {
32   cd ${pkgbase}_${pkgver}
33   bash bootStrap.bash --with-core --with-cli --with-plugins
36 package_avidemux-cli() {
37   depends=('libxml2' 'fontconfig' 'sqlite' 'libvpx' 'libva' 'libvdpau')
38   optdepends=('lame: for the corresponding audio encoder plugin'
39               'faac: for the corresponding audio encoder plugin'
40               'faad2: for the corresponding audio decoder plugin'
41               'opus: for the corresponding audio decoder plugin'
42               'opencore-amr: for the corresponding audio decoder plugin'
43               'jack: for the corresponding audio device plugin'
44               'libpulse: for the corresponding audio device plugin'
45               'x264: for the corresponding video encoder plugin'
46               'libx264: for the corresponding video encoder plugin'
47               'x265: for the corresponding video encoder plugin'
48               'xvidcore: for the corresponding video encoder plugin'
49               'qt5-base: for the QtScript scripting support'
50               'libdca: for the corresponding audio decoder plugin'
51               'libfdk-aac: for the corresponding audio decoder plugin'
52               'twolame: for the corresponding audio decoder plugin'
53               'libass: for the corresponding video filter plugin'
54               'fribidi: for the corresponding video filter plugin')
56   cd ${pkgbase}_${pkgver}
57   make -C buildCli DESTDIR="${pkgdir}" install
58   make -C buildCore DESTDIR="${pkgdir}" install
59   make -C buildPluginsCLI DESTDIR="${pkgdir}" install
60   make -C buildPluginsCommon DESTDIR="${pkgdir}" install
62   install -Dm 644 avidemux_icon.png "${pkgdir}/usr/share/pixmaps/avidemux.png"
63   install -Dm 644 man/avidemux.1 -t "${pkgdir}/usr/share/man/man1"
66 package_avidemux-qt() {
67   pkgdesc='Graphical tool to edit video (filter/re-encode/split) - Qt GUI'
68   depends=("avidemux-cli=${pkgver}" 'qt5-base' 'x264' 'x265' 'glu' 'libxv' 'desktop-file-utils')
69   replaces=('avidemux-gtk')
71   cd ${pkgbase}_${pkgver}
72   make -C buildQt5 DESTDIR="${pkgdir}" install
73   make -C buildPluginsQt5 DESTDIR="${pkgdir}" install
76 # vim: ts=2 sw=2 et: