net-misc/ssh-agent-shared
[anomen-overlay.git] / net-misc / wolman / wolman-9999-r1.ebuild
blobe36167c78c61b0358336b28d89c1e50370bec82c
1 # Copyright 1999-2006 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
5 EAPI="2"
7 inherit git qt4
9 EGIT_REPO_URI="git://git.dolezel.info/${PN}.git"
10 DESCRIPTION="GUI Wake-on-LAN manager"
11 HOMEPAGE="http://www.dolezel.info/projects/wolman"
12 SRC_URI=""
14 LICENSE="GPL-3"
15 SLOT="0"
16 KEYWORDS="x86 amd64"
17 IUSE=""
19 DEPEND=" x11-libs/qt-gui:4
20 net-libs/libnet
21 net-libs/libpcap"
22 RDEPEND="${DEPEND}
23 sys-apps/iproute2"
25 S="${WORKDIR}/${PN}"
27 src_unpack() {
28 git_src_unpack
31 src_compile() {
32 eqmake4
33 emake || die "make failed"
36 src_install() {
37 dosbin wolman || die "dosbin failed"
38 newicon gfx/green.png ${PN}.png
39 make_desktop_entry ${PN} "Wake-on-LAN manager" ${PN} "Network;RemoteAccess;Qt" /usr/sbin