dev-util/idea-* minor fixes
[anomen-overlay.git] / www-apps / pmwiki / pmwiki-2.2.15.ebuild
blob61dd2ecd828f2ae8ff2e302a7ba9216c3409e95d
1 # Copyright 1999-2005 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
5 inherit webapp
7 DESCRIPTION="Wiki primarily designed as a tool to support easy, collaborative
8 authoring and maintenance of web sites"
9 HOMEPAGE="http://www.pmwiki.org/"
10 SRC_URI="http://www.pmwiki.org/pub/pmwiki/${P}.tgz http://www.pmwiki.org/pub/pmwiki/older-releases/${P}.tgz"
12 LICENSE="GPL-2"
13 IUSE=""
14 KEYWORDS="~amd64 ~x86"
16 DEPEND=""
17 RDEPEND="dev-lang/php"
19 src_install() {
20 webapp_src_preinst
22 # Creating a default config file
23 cp "${FILESDIR}/sample-config.php" local/config.php
25 # This directory is needed by pmwiki, here it stores its files
26 mkdir "${D}/${MY_HTDOCSDIR}/wiki.d"
27 keepdir "${D}/${MY_HTDOCSDIR}/wiki.d"
28 webapp_serverowned "${MY_HTDOCSDIR}/wiki.d"
30 # Create the files upload directory
31 mkdir "${D}/${MY_HTDOCSDIR}/uploads"
32 keepdir "${D}/${MY_HTDOCSDIR}/uploads"
33 webapp_serverowned "${MY_HTDOCSDIR}/uploads"
35 # Removing unecessary files
36 rm COPYING
38 # Install to webapp-config master directory
39 cp -a * "${D}/${MY_HTDOCSDIR}"
41 webapp_configfile "${MY_HTDOCSDIR}/local/config.php"
43 webapp_postinst_txt en "${FILESDIR}/postinstall-en.txt"
45 webapp_src_install