www-apps/gc_fallout - dev - db
[anomen-overlay.git] / media-video / handbrake / handbrake-9999.ebuild
blob1466522448e93ae99d4eee931c3207bfa4fe4f83
1 # Copyright 1999-2007 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
5 EAPI="2"
7 ESVN_REPO_URI="svn://svn.handbrake.fr/HandBrake/trunk"
9 inherit subversion gnome2-utils
11 DESCRIPTION="Open-source DVD to MPEG-4 converter."
12 HOMEPAGE="http://handbrake.fr/"
13 LICENSE="GPL-2"
14 SLOT="0"
16 KEYWORDS="~x86 ~amd64"
18 IUSE="css doc gtk"
19 RDEPEND="sys-libs/zlib
20 css? ( media-libs/libdvdcss )
21 gtk? ( >=x11-libs/gtk+-2.8
22 dev-libs/glib
23 dev-libs/dbus-glib
24 x11-libs/libnotify
25 media-libs/gstreamer
26 media-libs/gst-plugins-base
27 >=sys-fs/udev-147[extras]
29 DEPEND="=sys-devel/automake-1.10*
30 =sys-devel/automake-1.4*
31 =sys-devel/automake-1.9*
32 dev-lang/yasm
33 >=dev-lang/python-2.4.6
34 || ( >=net-misc/wget-1.11.4 >=net-misc/curl-7.19.4 )
35 $RDEPEND"
37 src_configure() {
38 local myconf=""
40 ! use gtk && myconf="${myconf} --disable-gtk"
42 ./configure --force --prefix=/usr --disable-gtk-update-checks ${myconf} || die "configure failed"
45 src_compile() {
46 WANT_AUTOMAKE=1.9 emake -C build || die "failed compiling ${PN}"
49 src_install() {
50 emake -C build DESTDIR="${D}" install || die "failed installing ${PN}"
52 if use doc; then
53 emake -C build doc
54 dodoc AUTHORS CREDITS NEWS THANKS \
55 build/doc/articles/txt/* || die "docs failed"
59 pkg_preinst() {
60 gnome2_icon_savelist
63 pkg_postinst() {
64 gnome2_icon_cache_update
67 pkg_postrm() {
68 gnome2_icon_cache_update