dbvis
[anomen-overlay.git] / dev-python / pyexcelerator / pyexcelerator-0.6.4.1.ebuild
blob73ad070d4ebc86435f71e44df9091f071f2cd502
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
5 EAPI="3"
6 PYTHON_DEPEND="2"
7 SUPPORT_PYTHON_ABIS="1"
8 RESTRICT_PYTHON_ABIS="3.*"
10 inherit distutils
12 DESCRIPTION="Python im-/export filters for MS Excel files. Including xls2txt, xls2csv and xls2html commands."
13 HOMEPAGE="http://sourceforge.net/projects/pyexcelerator"
14 SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
15 RESTRICT="mirror"
17 LICENSE="BSD-4"
18 SLOT="0"
19 KEYWORDS="~amd64 ~x86"
20 IUSE="examples"
22 src_install() {
23 distutils_src_install
25 dobin tools/xls2csv.py || die
26 dobin tools/xls2html.py || die
27 dobin tools/xls2txt.py || die
29 if use examples ; then
30 insinto /usr/share/doc/${PF}/examples
31 doins -r examples/* || die