dev-vcs/mercurial-extensions - minor update
[anomen-overlay.git] / dev-vcs / mercurial-extensions / mercurial-extensions-2014.01.10.ebuild
blobb9673aacab73be135a848bc1791d328fa60fad50
1 # Copyright 1999-2010 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header$
4 EAPI="4"
6 DESCRIPTION="Various Mercurial extensions"
7 HOMEPAGE="http://mercurial.selenic.com/"
8 SRC_URI="
9 https://bitbucket.org/Mekk/mercurial_keyring/raw/fb4371a55e795782738fec1f85b5635e59ad8f44/mercurial_keyring.py -> fb4371a55e795782738fec1f85b5635e59ad8f44-mercurial_keyring.py
10 https://bitbucket.org/gobell/hg-zipdoc/raw/a2ca45ccfd648e714ae6f1f4ad437260aa161496/zipdoc.py -> a2ca45ccfd648e714ae6f1f4ad437260aa161496-zipdoc.py
11 https://bitbucket.org/birkenfeld/hgchangelog/raw/bb962d35fd2bcb396502f4e24840f24585614dec/hgchangelog.py -> bb962d35fd2bcb396502f4e24840f24585614dec-hgchangelog.py
12 https://bitbucket.org/jinhui/hg-cloc/raw/9a7c5cf25816b72ccb3eaf1fa3255e565a2e4e0a/cloc.py -> 9a7c5cf25816b72ccb3eaf1fa3255e565a2e4e0a-cloc.py
13 https://bitbucket.org/abuehl/hgext-cifiles/raw/091b6a4b561b65aa70f23f5cf8285e5e23676445/cifiles.py -> 091b6a4b561b65aa70f23f5cf8285e5e23676445-cifiles.py
14 https://bitbucket.org/face/timestamp/raw/e85aaaa0a21a9710af1865b828188ff30e19399e/casestop.py -> e85aaaa0a21a9710af1865b828188ff30e19399e-casestop.py
17 RESTRICT="mirror"
18 LICENSE="GPL-2+ as-is"
19 SLOT="0"
20 KEYWORDS="amd64 x86"
21 IUSE=""
23 DEPEND=""
24 RDEPEND="dev-vcs/mercurial"
26 S="${WORKDIR}"
28 src_unpack() {
29 cd "${DISTDIR}"
30 for FILE in *.py
32 cp "${FILE}" "$S/${FILE#*-}"
33 done
36 src_install() {
37 local dir=/usr/libexec/hgext
38 insinto "${dir}"
39 doins *.py