move libdmtx
[anomen-overlay.git] / dev-util / soapui / soapui-4.6.0.ebuild
blob700c22ff10755cf2ed8ae242154c844aeed5f623
1 # Copyright 1999-2011 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
5 EAPI="4"
6 inherit eutils versionator
8 DESCRIPTION="SoapUI webservice testing tool"
9 HOMEPAGE="http://www.soapui.org/"
10 SRC_URI="mirror://sourceforge/project/${PN}/${PN}/$PV/${P}-linux-bin.tar.gz"
11 LICENSE="soapui"
12 SLOT="0"
13 IUSE=""
14 KEYWORDS="~x86 ~amd64"
16 RDEPEND=">=virtual/jdk-1.6"
18 src_install() {
19 local dir="/opt/${P}"
21 insinto "${dir}"
22 doins -r *
23 for exe in loadtestrunner.sh mockservicerunner.sh securitytestrunner.sh soapui.sh testrunner.sh toolrunner.sh wargenerator.sh
25 fperms 755 "${dir}/bin/${exe}"
26 done
28 newicon "bin/soapui32.png" "${PN}.png"
29 make_wrapper "${PN}" "/opt/${P}/bin/${PN}.sh"
30 make_desktop_entry ${PN} "SoapUI" "${PN}" "Development;IDE"