Use PREFIX in install rule.
[SysBars.git] / debian / rules
blob0b119dce76b20811f1faf30556fae643937d8b4c
1 #!/usr/bin/make -f
2 # -*- makefile -*-
3 # Sample debian/rules that uses debhelper.
4 # This file was originally written by Joey Hess and Craig Small.
5 # As a special exception, when this file is copied by dh-make into a
6 # dh-make output file, you may use that output file without restriction.
7 # This special exception was added by Craig Small in version 0.37 of dh-make.
9 # Uncomment this to turn on verbose mode.
10 #export DH_VERBOSE=1
14 include /usr/share/dpatch/dpatch.make
16 clean: unpatch
17 dh_testdir
18 dh_testroot
20 # Add here commands to clean up after the build process.
22 dh_clean
24 install: patch
25 dh_testdir
26 dh_testroot
27 dh_prep
28 dh_installdirs
30 # Add here commands to install the package into debian/sysbars.
31 python install.py DEST_DIR=$(CURDIR)/debian/sysbars-applet PREFIX=/usr
34 # Build architecture-independent files here.
35 binary-indep: install
36 dh_testdir
37 dh_testroot
38 dh_installchangelogs
39 dh_installdocs
40 dh_installexamples
41 # dh_install
42 # dh_installmenu
43 # dh_installdebconf
44 # dh_installlogrotate
45 # dh_installemacsen
46 # dh_installpam
47 # dh_installmime
48 # dh_installinit
49 # dh_installcron
50 # dh_installinfo
51 # dh_installwm
52 # dh_installudev
53 # dh_lintian
54 # dh_undocumented
55 # dh_installman
56 dh_link
57 dh_compress
58 dh_fixperms
59 # dh_perl
60 # dh_python
61 dh_pysupport /usr/lib/sysbars
62 dh_installdeb
63 dh_gencontrol
64 dh_md5sums
65 dh_builddeb
67 # Build architecture-dependent files here.
68 binary-arch: install
70 binary: binary-indep binary-arch
71 .PHONY: build clean binary-indep binary-arch binary install configure