s3:lib/events: make use of samba_tevent_set_debug()
[Samba/gebeck_regimport.git] / BUILD_SYSTEMS.txt
blobf8590f6375ad6441e220536bc7f592e210476102
1 BUILDING SAMBA 4.0
2 (which build system to use and why)
3 ===================================
5 The waf build
6 -------------
8 Samba 4.0 ships with a new build system, based on waf.  A background to
9 this build system can be found at https://wiki.samba.org/index.php/Waf
11 This is the build system that is used when you run ./configure && make
12 in the top level of a Samba 4.0 release tree.
14 For the vast majority of our users, this is the build system you should
15 use.  It supports parallel and incremental builds, and builds the whole
16 Samba suite, the file server, the print server, the NT4 domain
17 controller, winbind, the AD Domain Controller, the client libraries and
18 the python libraries.  
20 A key feature for many of our distributors and OEMs is that despite the
21 range of additional features, the resulting binaries and libraries are
22 substantially smaller, because we use shared libraries extensively. 
24 For distributions that have a requirement to use the system-supplied
25 Kerberos library, we support building against a Heimdal or system MIT
26 Kerberos library, provided the version is recent enough (otherwise we
27 will use our internal version of Heimdal).  Please note that builds
28 with MIT krb5 support will not have AD DC features.
30 Where we provide a tool under a name that was used in Samba 3.x, it
31 continues to behave in the same way it always has.  This will ensure
32 that our change in build system does not impact on our user's ability
33 to use Samba as they always have.
35 For developers, this build system backs a comprehensive 'make test',
36 which provides code coverage of around 48% of our code by line:
37 https://build.samba.org/lcov/data/coverage/samba_4_0_test/
39 This build system also implements important features such as ABI
40 checking (which protects you as users from accidental changes to our
41 published libraries), symbol versions and dependency checked incremental
42 rebuilds after header-file changes. 
44 The waf build also assists developers by providing fully-linked binaries
45 that run from bin/ without needing to set LD_LIBRARY_PATH. 
47 For users who do not have python installed on their systems, we provide
48 a install_with_python.sh script, which will install a local copy of
49 python sufficient to run the build system, without impacting on the rest
50 of the system.  
52 Within this requirement, we expect that this build will run on all our
53 supported platforms, and will actively deal with any portability issues
54 that users can bring to our attention. 
56 For all these reasons, we highly recommend this new build system to all
57 our users, for whatever purpose you want to put Samba to.
59 The autoconf build
60 ------------------
62 For a small number of users, the requirement to have access to Python
63 2.4 and perl will be unacceptable, and for these users we continue to
64 provide the 'autoconf' build system used in Samba 3.x under the
65 source3/.  This will build fewer parts of Samba, but should not be seen
66 as 'the file server build' (typical file server deployments should use
67 the top level build), but as a measure provided with limited features
68 for systems and organisations unable to meet the requirements for the
69 new build system.
71 If you do need to use the autoconf build system, please let us know:
72 both why you cannot use the 'waf' build in the top level, and what
73 features of the source3 build that you require.  We need this
74 information to assess the continuing demand for this parallel
75 infrastructure, and to determine which features need to remain available
76 in both build systems.
78 Optional Libraries
79 ------------------
81 To assist users and distributors to build Samba with the full feature
82 set, by the first release candidate the build system will abort if our
83 dependent libraries and their header files are not found on the target
84 system.  This will mean for example, that xattr, acl and ldap headers
85 must be installed for the default build to complete.  The configure
86 system will check for these headers, and the error message will
87 indicate:
88  - the required header and library
89  - the option (such as --without-acl-support) that can be specified to
90    skip this requirement, and
91  - the feature (ACL support optional for file servers, mandatory for AD
92    Domain Controller) being skipped. 
94 This will assist users and in particular distributors in building fully
95 functional packages, while allowing those on systems truly without these
96 facilities to continue to build Samba after careful consideration.