tevent_poll: add poll_event_loop_wait()
[Samba/gebeck_regimport.git] / upgrading-samba4.txt
blob8c74f5aae5840b34526214ef4d1b5306fc3a52c6
1 Upgrading from an older samba4 installation.
3 * Compile the new version of samba4 by following the HOWTO, but do
4   not install it yet, and do not run provision.
5 * Stop any samba process
6 * Backup your samba4 provision:
7   go into the directory where your samba4 provision is stored (/usr/local/samba by default)
8   do tar cf $HOME/backup.tar private etc var sysvol
9 * do make install
10 * run 'samba-tool dbcheck'
12 This will do a consistency check of the data, and is all most existing
13 installations will require.
15 If you are upgrading from a quite old provision (Samba 4.0 alpha 13 or
16 earlier) then running upgradeprovision will do an upgrade of security
17 descriptors, and upgradeprovision --full will perform a more
18 comprehensive upgrade of the data (including schema and display
19 specifiers).  This attempts to do a new provision, and to then copy
20 existing data into that database.
22 If you are upgrading from a more recent version, particularly alpha16
23 or later, then it is better *NOT* to run upgradeprovision as the
24 database format has not changed.
26 To upgrade from BIND9 flat files to the internal database store for
27 Bind 9 DLZ, use ./source4/scripting/bin/samba_upgradedns