libcli/smb: move smb2cli_flush.c from source3 to the toplevel
[Samba/gebeck_regimport.git] / libcli / smb / wscript_build
blob5c4fe62123a4c85e3c5dfa532b0ef839ea40cfdb
1 #!/usr/bin/env python
4 bld.SAMBA_LIBRARY('cli_smb_common',
5 source='''
6 smb_signing.c smb_seal.c
7 smb2_create_blob.c smb2_signing.c
8 util.c read_smb.c
9 smbXcli_base.c
10 smb1cli_trans.c
11 smb2cli_session.c
12 smb2cli_create.c
13 smb2cli_close.c
14 smb2cli_read.c
15 smb2cli_write.c
16 smb2cli_flush.c
17 ''',
18 deps='LIBCRYPTO errors gensec krb5samba LIBASYNC_REQ',
19 public_deps='talloc samba-util',
20 private_library=True,
21 public_headers='''
22 smb_common.h smb2_constants.h smb_constants.h
23 smb_signing.h smb_seal.h
24 smb2_create_blob.h smb2_signing.h
25 smb_util.h read_smb.h
26 smb_unix_ext.h
27 ''',