2 # "$Id: lsb-samba.spec,v 1.2 2001/07/03 01:01:12 jra Exp $"
4 # Linux Standards Based RPM "spec" file for SAMBA.
12 Group: System Environment
/Daemons
13 Source: ftp
://ftp.samba.org
/pub
/samba
/samba
-%{version}.tar.gz
14 Url
: http
://www.samba.org
15 Packager: Michael Sweet
<mike@easysw.com
>
18 # Require the "lsb" package, which guarantees LSB compliance.
21 # use BuildRoot so as not to disturb the version already installed
22 BuildRoot: /var
/tmp
/%{name}-root
30 export LDFLAGS
="
-L
/usr
/lib
/lsb
--dynamic
-linker
=/lib
/ld
-lsb.so
.1"
32 .
/configure
--with
-fhs
--prefix
=/usr
--sysconfdir
=/etc \
33 --sharedstatedir
=/var
--datadir
=/usr
/share \
34 --with
-configdir
=/etc
/samba \
35 --with
-swatdir
=/usr
/share
/samba
/swat
37 # If we got this far, all prerequisite libraries must be here.
41 # Make sure the RPM_BUILD_ROOT directory exists.
42 rm -rf $RPM_BUILD_ROOT
46 BASEDIR
=$RPM_BUILD_ROOT
/usr \
47 BINDIR
=$RPM_BUILD_ROOT
/usr
/bin \
48 CODEPAGEDIR
=$RPM_BUILD_ROOT
/usr
/share
/samba
/codepages \
49 CONFIGDIR
=$RPM_BUILD_ROOT
/etc
/samba \
50 INCLUDEDIR
=$RPM_BUILD_ROOT
/usr
/include \
51 LIBDIR
=$RPM_BUILD_ROOT
/usr
/lib \
52 LOCKDIR
=$RPM_BUILD_ROOT
/var
/lock
/samba \
53 LOGFILEBASE
=$RPM_BUILD_ROOT
/var
/log
/samba \
54 MANDIR
=$RPM_BUILD_ROOT
/usr
/share
/man \
55 SBINDIR
=$RPM_BUILD_ROOT
/usr
/sbin \
56 SWATDIR
=$RPM_BUILD_ROOT
/usr
/share
/samba
/swat \
57 VARDIR
=$RPM_BUILD_ROOT
/var \
60 mkdir -p $RPM_BUILD_ROOT
/etc
/init.d
61 install -m
700 packaging
/LSB
/samba.sh
/etc
/init.d
/samba
63 mkdir -p $RPM_BUILD_ROOT
/etc
/samba
64 install -m
644 packaging
/LSB
/smb.conf
/etc
/samba
66 mkdir -p $RPM_BUILD_ROOT
/etc
/xinetd.d
67 install -m
644 packaging
/LSB
/samba.xinetd
/etc
/xinetd.d
/samba
70 /usr
/lib
/lsb
/install_initd
/etc
/init.d
/samba
73 /usr
/lib
/lsb
/remove_initd
/etc
/init.d
/samba
76 rm -rf $RPM_BUILD_ROOT
83 %config(noreplace
) /etc
/samba
/smb.conf
84 %dir /etc
/samba
/private
86 %config(noreplace
) /etc
/xinetd.d
/samba
99 # End of "$Id: lsb-samba.spec,v 1.2 2001/07/03 01:01:12 jra Exp $".