New RPM builder spec file
[MonkeyD.git] / monkey.spec
blobe6b961043930c6e4b15f00203bda128094638736
1 %define branch 0.11
2 %define webroot /var/www/monkey
3 %define prefix /usr
4 %define bindir /usr/bin
5 %define sysconf /etc/monkey
6 %define logdir /var/log/monkey
7 %define plugdir /usr/lib/monkey
9 Summary: Monkey is a Fast and Lightweight Web Server for Linux
10 Name: monkey
11 Version: 0.11.0
12 Packager: Eduardo Silva <edsiper@gmail.com>
13 Release: 1%{dist}
14 License: GPL
15 Group: System Environment/Daemons
16 Source: http://www.monkey-project.com/releases/%{branch}/%{name}-%{version}.tar.gz
17 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
18 URL: http://www.monkey-project.com
20 %description
21 Monkey is a really fast and lightweight Web Server for Linux. It has been
22 designed to be very scalable with low memory and CPU consumption, the perfect
23 solution for embedded and high production environments.
25 %prep
26 %setup
27 %build
28 export CFLAGS=$RPM_OPT_FLAGS
29 ./configure \
30 --prefix=%{prefix} \
31 --bindir=%{bindir} \
32 --sysconfdir=%{sysconf} \
33 --datadir=%{webroot} \
34 --logdir=%{logdir} \
35 --plugdir=%{plugdir}
37 make
39 %install
40 rm -rf %{buildroot}
41 install -d %{buildroot}/usr/share/doc
43 make DESTDIR=%{buildroot} install
45 %clean
46 rm -rf %{buildroot}
48 %files
49 %defattr(-,root,root)
50 %doc README LICENSE ChangeLog*
51 %attr(644,root,root) %{_sysconfdir}/monkey/*
52 %{_bindir}/*
53 %{_libdir}/*
54 %{_datadir}/*
55 %{webroot}/*
57 %changelog
58 * Thu Jul 08 2010 Eduardo Silva <edsiper at, gmail.com> 0.11.0-1
59 - Initial rpm package for Fedora 13