Adjusted the source-url in man-pages PKGBUILD
[Archlinux-Stable.git] / base / man-pages / PKGBUILD
blob6e02604fd6bee02a4b180d5e940169108a3991aa
1 # $Id: PKGBUILD,v 1.74 2007/12/30 10:21:55 andyrtr Exp $
2 # Maintainer: judd <jvinet@zeroflux.org>
3 pkgname=man-pages
4 pkgver=2.74
5 pkgrel=2
6 pkgdesc="Linux man pages"
7 arch=(i686 x86_64)
8 license=('GPL')
9 url="http://www.win.tue.nl/~aeb/linux/man"
10 groups=('base')
11 depends=()
12 source=(http://www.kernel.org/pub/linux/docs/man-pages/Archive/$pkgname-$pkgver.tar.gz)
13 md5sums=('d2c7ff067c1beb82dabbfe4d9f49cd5e')
15 build() {
16   cd $startdir/src/$pkgname-$pkgver
17   make prefix=$startdir/pkg/usr install
19   cd $startdir/pkg/usr/share/man
20   # these are included in coreutils
21   rm -f man1/{chgrp,chmod,chown,cp,dir,dd}.1
22   rm -f man1/{df,dircolors,du,install,ln,ls}.1
23   rm -f man1/{mkdir,mkfifo,mknod,mv,rm,rmdir}.1
24   rm -f man1/{touch,vdir}.1
25   # this is included in shadow
26   rm -f man5/passwd.5
27   rm -f man3/getspnam.3
28   # this is included in diffutils
29   rm -f man1/diff.1
30   # this is included in xf86-input-mouse
31   rm -f man4/mouse.4
32   # these are included in module-init-tools
33   rm -f man2/{create_module,delete_module,get_kernel_syms}.2
34   rm -f man2/{init_module,query_module}.2