logrotate PKGBUILD updated
[Archlinux-Stable.git] / base / logrotate / PKGBUILD
blob86bfb20c1baf273e411930e5cf17c39059886748
1 # $Id: PKGBUILD,v 1.19 2008/01/08 06:41:25 aaron Exp $
2 # Maintainer: Aaron Griffin <aaron@archlinux.org>
3 # Contributor: Judd Vinet <jvinet@zeroflux.org>
5 pkgname=logrotate
6 pkgver=3.7.5
7 pkgrel=1
8 pkgdesc="Rotates system logs automatically"
9 url='http://rhlinux.redhat.com'
10 arch=(i686 x86_64)
11 license=('GPL')
12 groups=('base')
13 depends=('popt' 'cron' 'gzip')
14 backup=('etc/logrotate.conf')
16 # The source is apparently a CVS checkout only. Create the tarball like so:
17 # cvs -d :pserver:anonymous@rhlinux.redhat.com:/usr/local/CVS co logrotate
18 # cd logrotate/
19 # make create-archive
20 # Ensure this tarball is places in other/logrotate/
22 source=(ftp://ftp.archlinux.org/other/logrotate/${pkgname}-${pkgver}.tar.gz
23         logrotate.conf logrotate.cron.daily)
24 md5sums=('a1a3ea2f1d80e67e902c024bbdef616a'
25          'c8b915903825befc401797b7620f249e'
26          '8e23d5d4cc29b1e055b24df87e355cdc')
28 build() {
29   cd $startdir/src/${pkgname}-${pkgver}
31   sed -i 's|#define DEFAULT_MAIL_COMMAND .*|#define DEFAULT_MAIL_COMMAND "/usr/bin/mail"|'\
32     config.h
33   make || return 1
34   make PREFIX=$startdir/pkg install
35   install -D -m644 ../logrotate.conf $startdir/pkg/etc/logrotate.conf
36   install -D -m744 ../logrotate.cron.daily $startdir/pkg/etc/cron.daily/logrotate