debian: Import version 0.95.6-1.
[wmaker-crm.git] / debian / patches / 55_ungif_problem.diff
blob2c59883c77b353318db7a3ecbf44c9ad22399269
1 Description: Remove include ungif library (will use gif library)
2 Author: Rodolfo García Peñas (kix) <kix@debian.org>
3 Last-Update: 2014-10-09
4 Index: WindowMaker-0.95.6/m4/wm_imgfmt_check.m4
5 ===================================================================
6 --- WindowMaker-0.95.6.orig/m4/wm_imgfmt_check.m4
7 +++ WindowMaker-0.95.6/m4/wm_imgfmt_check.m4
8 @@ -19,7 +19,7 @@
9 # WM_IMGFMT_CHECK_GIF
10 # -------------------
12 -# Check for GIF file support through 'libgif', 'libungif' or 'giflib v5'
13 +# Check for GIF file support through 'libgif' or 'giflib v5'
14 # The check depends on variable 'enable_gif' being either:
15 # yes - detect, fail if not found
16 # no - do not detect, disable support
17 @@ -37,7 +37,7 @@ AS_IF([test "x$enable_gif" = "xno"],
18 wm_save_LIBS="$LIBS"
19 dnl
20 dnl We check first if one of the known libraries is available
21 - for wm_arg in "-lgif" "-lungif" ; do
22 + for wm_arg in "-lgif" ; do
23 AS_IF([wm_fn_lib_try_link "DGifOpenFileName" "$XLFLAGS $XLIBS $wm_arg"],
24 [wm_cv_imgfmt_gif="$wm_arg" ; break])
25 done