wmaker: Add keyboard shortcuts for keeping window on top or at bottom.
[wmaker-crm.git] / debian / rules
blobee55594019081393bc7ad66a31ec0336f94d54a6
1 #!/usr/bin/make -f
2 # export DH_VERBOSE=1
3 export DEB_CFLAGS_MAINT_APPEND += -Wall -DGLOBAL_DEFAULTS_SUBDIR=\"GNUstep/Defaults\"
5 LINGUAS := $(patsubst po/%.po, %, $(wildcard po/*.po))
7 WMAKER_OPTIONS := --disable-locale --enable-modelock --enable-randr --enable-pango --enable-xinerama
8 #not-enabled --enable-usermenu --disable-shape --disable-shm --enable-xrandr
9 #not-enabled --disable-xpm --disable-png --disable-jpeg --disable-gif --disable-tiff
11 # Debian packages destination folder
12 DEBIAN_TMP := debian/tmp
14 # Be careful with the leading / because some of these values are going
15 # to be hardcoded into the executables
16 BASEDIR := /usr
17 INCLUDEDIR := $(BASEDIR)/include
18 SHAREDIR := $(BASEDIR)/share
19 NLSDIR := $(SHAREDIR)/locale
20 GNUSTEPDIR := $(SHAREDIR)/lib/GNUstep/System
21 WMSHAREDIR := $(SHAREDIR)/WindowMaker
22 PIXMAPDIR := $(INCLUDEDIR)/X11/pixmaps
24 COMMON_OPTIONS := --datadir=$(SHAREDIR) \
25 --with-localedir=$(NLSDIR) \
26 --with-pixmapdir=$(PIXMAPDIR) \
27 --with-gnustepdir=$(GNUSTEPDIR)
30 dh $@ --parallel --with autoreconf
32 override_dh_auto_configure:
33 env LINGUAS="$(LINGUAS)" dh_auto_configure --verbose -- \
34 $(COMMON_OPTIONS) $(WMAKER_OPTIONS)
36 override_dh_installmenu:
37 dh_installmenu -a --noscripts
39 override_dh_install:
40 # Fix perms for /usr/share/WindowMaker/*sh before install them
41 chmod +x $(DEBIAN_TMP)$(WMSHAREDIR)/autostart.sh
42 chmod +x $(DEBIAN_TMP)$(WMSHAREDIR)/exitscript.sh
44 # Readmes - Copy+rename before install
45 # We use the root of the temporal directory debian/tmp
46 cp po/README $(DEBIAN_TMP)/README.po
47 cp README.definable-cursor $(DEBIAN_TMP)/README.definable-cursor
48 cp WPrefs.app/README $(DEBIAN_TMP)/README.WPrefs
49 cp WPrefs.app/po/README $(DEBIAN_TMP)/README.WPrefs.po
51 # Now, change the #wmdatadir# string to $(WMSHAREDIR)
52 perl -pi -e 's:#wmdatadir#:$(WMSHAREDIR):' `find $(DEBIAN_TMP)/$(WMSHAREDIR) -name plmenu.*`
53 perl -pi -e 's:#wmdatadir#:$(WMSHAREDIR):' $(DEBIAN_TMP)$(WMSHAREDIR)/wmmacros
54 perl -pi -e 's:#wmdatadir#:$(WMSHAREDIR):' $(DEBIAN_TMP)$(WMSHAREDIR)/plmenu
56 # Install files
57 dh_install
59 override_dh_strip:
60 dh_strip --dbg-package=wmaker-dbg