WINGs: Added a few missing const attributes
[wmaker-crm.git] / debian / wmaker.postinst
blobd3f1d399b875876f4791803b45e76b3ca3692cb1
1 #!/bin/sh
2 set -e
4 # Window Maker postinst.
5 #
6 # Marcelo Magallon <mmagallo@debian.org>
7 # Rodolfo "kix" GarcĂ­a <kix@kix.es>
9 x_wm_link=/etc/alternatives/x-window-manager
10 x_wm_man_link=/usr/share/man/man1/x-window-manager.1.gz
12 inst="/etc/menu-methods/wmaker"
14 case "$1" in
15 configure)
16 for file in $inst ; do
17 if [ -f $file ] ; then
18 chmod a+x $file
20 done
22 update-alternatives --install /usr/bin/x-window-manager \
23 x-window-manager /usr/bin/wmaker 50 \
24 --slave /usr/share/man/man1/x-window-manager.1.gz \
25 x-window-manager.1.gz /usr/share/man/man1/wmaker.1x.gz
27 if [ -x /usr/bin/update-menus -a -x /usr/bin/install-menu ] ; then
28 update-menus
32 abort-upgrade|abort-deconfigure|abort-remove)
33 # how did we got here? Force a non-zero exit code
34 exit 1
38 echo "postinst called with unkown argument: \$1" >&2
40 esac
42 #DEBHELPER#
44 exit 0