WINGs: Added a few missing const attributes
[wmaker-crm.git] / debian / wmaker-common.postinst
blob63ca5777028d10db23a204f0bffc0bb851e9f876
1 #!/bin/sh
2 set -e
4 # Window Maker postinst.
6 # Marcelo Magallon <mmagallo@debian.org>
7 # Rodolfo "kix" GarcĂ­a <kix@kix.es>
9 inst="/etc/menu-methods/wmappearance"
11 case "$1" in
12 configure)
13 for file in $inst ; do
14 if [ -f $file ] ; then
15 chmod a+x $file
17 done
19 if [ -x /usr/bin/update-menus -a -x /usr/bin/install-menu ] ; then
20 # Remove the menu.hook from all the possible paths.
21 rm -f /etc/X11/WindowMaker/menu.hook
22 rm -f /usr/share/WindowMaker/menu.hook
23 # Remove appearance.menu
24 rm -f /usr/share/WindowMaker/appearance.menu
25 update-menus
29 abort-upgrade|abort-deconfigure|abort-remove)
30 # how did we got here? Force a non-zero exit code
31 exit 1
35 echo "postinst called with unkown argument: \$1" >&2
37 esac
39 #DEBHELPER#
41 exit 0