Release 0.4.10
[wine/multimedia.git] / if1632 / user.spec
blobbf032d68149de024e93327905978b3027d0a55d6
1 # $Id: user.spec,v 1.3 1993/07/04 04:04:21 root Exp root $
3 name user
4 id 2
5 length 540
7 1 pascal MessageBox(word ptr ptr word) MessageBox(1 2 3 4)
8 5 pascal InitApp(word) USER_InitApp(1)
9 6 pascal PostQuitMessage(word) PostQuitMessage(1)
10 10 pascal SetTimer(word word word ptr) SetTimer(1 2 3 4)
11 11 pascal SetSystemTimer(word word word ptr) SetSystemTimer(1 2 3 4)
12 12 pascal KillTimer(word word) KillTimer(1 2)
13 13 pascal GetTickCount() GetTickCount()
14 14 return GetTimerResolution 0 1000
15 15 pascal GetCurrentTime() GetTickCount()
16 18 pascal SetCapture(word) SetCapture(1)
17 19 pascal ReleaseCapture() ReleaseCapture()
18 20 pascal SetDoubleClickTime(word) SetDoubleClickTime(1)
19 21 pascal GetDoubleClickTime() GetDoubleClickTime()
20 22 pascal SetFocus(word) SetFocus(1)
21 23 pascal GetFocus() GetFocus()
22 31 pascal IsIconic(word) IsIconic(1)
23 32 pascal GetWindowRect(word ptr) GetWindowRect(1 2)
24 33 pascal GetClientRect(word ptr) GetClientRect(1 2)
25 36 pascal GetWindowText(word ptr word) GetWindowText(1 2 3)
26 37 pascal SetWindowText(word ptr) SetWindowText(1 2)
27 38 pascal GetWindowTextLength(word) GetWindowTextLength(1)
28 39 pascal BeginPaint(word ptr) BeginPaint(1 2)
29 40 pascal EndPaint(word ptr) EndPaint(1 2)
30 41 pascal CreateWindow(ptr ptr long s_word s_word s_word s_word word word word ptr)
31 CreateWindow(1 2 3 4 5 6 7 8 9 10 11)
32 42 pascal ShowWindow(word word) ShowWindow(1 2)
33 43 pascal CloseWindow(word) CloseWindow(1)
34 44 pascal OpenIcon(word) OpenIcon(1)
35 46 pascal GetParent(word) GetParent(1)
36 47 pascal IsWindow(word) IsWindow(1)
37 48 pascal IsChild(word word) IsChild(1 2)
38 49 pascal IsWindowVisible(word) IsWindowVisible(1)
39 50 pascal FindWindow(ptr ptr) FindWindow(1 2)
40 53 pascal DestroyWindow(word) DestroyWindow(1)
41 56 pascal MoveWindow(word word word word word word)
42 MoveWindow(1 2 3 4 5 6)
43 57 pascal RegisterClass(ptr) RegisterClass(1)
44 61 pascal ScrollWindow(word s_word s_word ptr ptr) ScrollWindow(1 2 3 4 5)
45 62 pascal SetScrollPos(word word word word) SetScrollPos(1 2 3 4)
46 64 pascal SetScrollRange(word word word word word) SetScrollRange(1 2 3 4 5)
47 66 pascal GetDC(word) GetDC(1)
48 68 pascal ReleaseDC(word word) ReleaseDC(1 2)
49 69 pascal SetCursor(word word) SetCursor(1 2)
50 71 pascal ShowCursor(word word) ShowCursor(1 2)
51 72 pascal SetRect(ptr s_word s_word s_word s_word) SetRect(1 2 3 4 5)
52 73 pascal SetRectEmpty(ptr) SetRectEmpty(1)
53 74 pascal CopyRect(ptr ptr) CopyRect(1 2)
54 75 pascal IsRectEmpty(ptr) IsRectEmpty(1)
55 76 pascal PtInRect(ptr long) PtInRect(1 2)
56 77 pascal OffsetRect(ptr s_word s_word) OffsetRect(1 2 3)
57 78 pascal InflateRect(ptr s_word s_word) InflateRect(1 2 3)
58 79 pascal IntersectRect(ptr ptr ptr) IntersectRect(1 2 3)
59 80 pascal UnionRect(ptr ptr ptr) UnionRect(1 2 3)
60 81 pascal FillRect(word ptr word) FillRect(1 2 3)
61 82 pascal InvertRect(word ptr) InvertRect(1 2)
62 83 pascal FrameRect(word ptr word) FrameRect(1 2 3)
63 84 pascal DrawIcon(word s_word s_word word) DrawIcon(1 2 3 4)
64 85 pascal DrawText(word ptr s_word ptr word) DrawText(1 2 3 4 5)
65 87 pascal DialogBox(word ptr word ptr) DialogBox(1 2 3 4)
66 88 pascal EndDialog(word s_word) EndDialog(1 2)
67 89 pascal CreateDialog(word ptr word ptr) CreateDialog(1 2 3 4)
68 90 pascal IsDialogMessage(word ptr) IsDialogMessage(1 2)
69 91 pascal GetDlgItem(word word) GetDlgItem(1 2)
70 92 pascal SetDlgItemText(word ptr) SetDlgItemText(1 2)
71 93 pascal GetDlgItemText(word word ptr word) GetDlgItemText(1 2 3 4)
72 94 pascal SetDlgItemInt(word word word word) SetDlgItemInt(1 2 3 4)
73 95 pascal GetDlgItemInt(word word ptr word) GetDlgItemInt(1 2 3 4)
74 96 pascal CheckRadioButton(word word word word) CheckRadioButton(1 2 3 4)
75 97 pascal CheckDlgButton(word word word) CheckDlgButton(1 2 3)
76 98 pascal IsDlgButtonChecked(word word) IsDlgButtonChecked(1 2)
77 101 pascal SendDlgItemMessage(word word word word long)
78 SendDlgItemMessage(1 2 3 4 5)
79 102 pascal AdjustWindowRect(ptr long word) AdjustWindowRect(1 2 3)
80 103 pascal MapDialogRect(word ptr) MapDialogRect(1 2)
81 104 pascal MessageBeep(word) MessageBeep(1)
82 106 pascal GetKeyState(word) GetKeyState(1)
83 107 pascal DefWindowProc(word word word long) DefWindowProc(1 2 3 4)
84 108 pascal GetMessage(ptr word word word) GetMessage(1 2 3 4)
85 109 pascal PeekMessage(ptr word word word word) PeekMessage(1 2 3 4 5)
86 110 pascal PostMessage(word word word long) PostMessage(1 2 3 4)
87 111 pascal SendMessage(word word word long) SendMessage(1 2 3 4)
88 113 pascal TranslateMessage(ptr) TranslateMessage(1)
89 114 pascal DispatchMessage(ptr) DispatchMessage(1)
90 118 pascal RegisterWindowMessage(ptr) RegisterWindowMessage(1)
91 119 pascal GetMessagePos() GetMessagePos()
92 120 pascal GetMessageTime() GetMessageTime()
93 122 pascal CallWindowProc(ptr word word word long) CallWindowProc(1 2 3 4 5)
94 124 pascal UpdateWindow(word) UpdateWindow(1)
95 125 pascal InvalidateRect(word ptr word) InvalidateRect(1 2 3)
96 126 pascal InvalidateRgn(word word word) InvalidateRgn(1 2 3)
97 127 pascal ValidateRect(word ptr) ValidateRect(1 2)
98 128 pascal ValidateRgn(word word) ValidateRgn(1 2)
99 129 pascal GetClassWord(word s_word) GetClassWord(1 2)
100 130 pascal SetClassWord(word s_word word) SetClassWord(1 2 3)
101 131 pascal GetClassLong(word s_word) GetClassLong(1 2)
102 132 pascal SetClassLong(word s_word long) SetClassLong(1 2 3)
103 133 pascal GetWindowWord(word s_word) GetWindowWord(1 2)
104 134 pascal SetWindowWord(word s_word word) SetWindowWord(1 2 3)
105 135 pascal GetWindowLong(word s_word) GetWindowLong(1 2)
106 136 pascal SetWindowLong(word s_word long) SetWindowLong(1 2 3)
107 150 pascal LoadMenu(word ptr) LoadMenu(1 2)
108 151 pascal CreateMenu() CreateMenu()
109 154 pascal CheckMenu(word word word) CheckMenu(1 2 3)
110 157 pascal GetMenu(word) GetMenu(1)
111 158 pascal SetMenu(word word) SetMenu(1 2)
112 171 pascal WinHelp(word word long) WinHelp(1 2 3)
113 173 pascal LoadCursor(word ptr) LoadCursor(1 2)
114 174 pascal LoadIcon(word ptr) LoadIcon(1 2)
115 175 pascal LoadBitmap(word ptr) LoadBitmap(1 2)
116 176 pascal LoadString(word word ptr s_word) LoadString(1 2 3 4)
117 177 pascal LoadAccelerators(word ptr) LoadAccelerators(1 2)
118 179 pascal GetSystemMetrics(word) GetSystemMetrics(1)
119 180 pascal GetSysColor(word) GetSysColor(1)
120 181 pascal SetSysColors(word ptr ptr) SetSysColors(1 2 3)
121 182 pascal KillSystemTimer(word word) KillSystemTimer(1 2)
122 190 pascal GetUpdateRect(word ptr word) GetUpdateRect(1 2 3)
123 218 pascal DialogBoxIndirect(word word word ptr) DialogBoxIndirect(1 2 3 4)
124 219 pascal CreateDialogIndirect(word ptr word ptr)
125 CreateDialogIndirect(1 2 3 4)
126 221 pascal ScrollDC(word s_word s_word ptr ptr word ptr)
127 ScrollDC(1 2 3 4 5 6 7)
128 227 pascal GetNextDlgGroupItem(word word word) GetNextDlgGroupItem(1 2 3)
129 228 pascal GetNextDlgTabItem(word word word) GetNextDlgTabItem(1 2 3)
130 229 pascal GetTopWindow(word) GetTopWindow(1)
131 230 pascal GetNextWindow(word word) GetNextWindow(1 2)
132 232 pascal SetWindowPos(word word word word word word word)
133 SetWindowPos(1 2 3 4 5 6 7)
134 237 pascal GetUpdateRgn(word word word) GetUpdateRgn(1 2 3)
135 239 pascal DialogBoxParam(word ptr word ptr long) DialogBoxParam(1 2 3 4 5)
136 240 pascal DialogBoxIndirectParam(word word word ptr long)
137 DialogBoxIndirectParam(1 2 3 4 5)
138 241 pascal CreateDialogParam(word ptr word ptr long)
139 CreateDialogParam(1 2 3 4 5)
140 242 pascal CreateDialogIndirectParam(word ptr word ptr long)
141 CreateDialogIndirectParam(1 2 3 4 5)
142 244 pascal EqualRect(ptr ptr) EqualRect(1 2)
143 262 pascal GetWindow(word word) GetWindow(1 2)
144 266 pascal SetMessageQueue(word) SetMessageQueue(1)
145 277 pascal GetDlgCtrlID(word) GetDlgCtrlID(1)
146 286 pascal GetDesktopWindow() GetDesktopWindow()
147 288 pascal GetMessageExtraInfo() GetMessageExtraInfo()
148 319 pascal ScrollWindowEx(word s_word s_word ptr ptr word ptr word)
149 ScrollWindowEx(1 2 3 4 5 6 7 8)
150 324 pascal FillWindow(word word word word) FillWindow(1 2 3 4)
151 325 pascal PaintRect(word word word word ptr) PaintRect(1 2 3 4 5)
152 334 pascal GetQueueStatus(word) GetQueueStatus(1)
153 335 pascal GetInputState() GetInputState()
154 373 pascal SubtractRect(ptr ptr ptr) SubtractRect(1 2 3)
155 403 pascal UnregisterClass(ptr word) UnregisterClass(1 2)
156 411 pascal AppendMenu(word word word ptr) AppendMenu(1 2 3 4)
157 420 pascal wsprintf(ptr ptr) wsprintf(1 2)
158 421 pascal wvsprintf(ptr ptr ptr) wvsprintf(1 2 3)
159 430 pascal lstrcmp(ptr ptr) lstrcmp(1 2)
160 431 pascal AnsiUpper(ptr) AnsiUpper(1)
161 432 pascal AnsiLower(ptr) AnsiLower(1)
162 433 pascal IsCharAlpha(byte) IsCharAlpha(1)
163 434 pascal IsCharAlphanumeric(byte) IsCharAlphanumeric(1)
164 435 pascal IsCharUpper(byte) IsCharUpper(1)
165 436 pascal IsCharLower(byte) IsCharLower(1)
166 437 pascal AnsiUpperBuff(ptr word) AnsiUpperBuff(1 2)
167 438 pascal AnsiLowerBuff(ptr word) AnsiLowerBuff(1 2)
168 452 pascal CreateWindowEx(long ptr ptr long s_word s_word s_word s_word
169 word word word ptr)
170 CreateWindowEx(1 2 3 4 5 6 7 8 9 10 11 12)
171 457 pascal DestroyIcon(word) DestroyIcon(1)
172 458 pascal DestroyCursor(word) DestroyCursor(1)
173 471 pascal lstrcmpi(ptr ptr) lstrcmpi(1 2)
174 472 pascal AnsiNext(ptr) AnsiNext(1 )
175 473 pascal AnsiPrev(ptr ptr) AnsiPrev(1 2)